Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Having issues building unity project with Visual Studio ?

Hi everyone I am at the point where I'd like to build an executable for my immersive app , The initial compilation of the VCproj seems to go off without a hitch however it seems like when compiling the IL2CPP file I am getting an error . The Error I see in the Visual Studio console says

Error MSB8020 The build tools for v141 (Platform Toolset = 'v141') cannot be found. To build using the v141 build tools, please install v141 build tools. Alternatively, you may upgrade to the current Visual Studio tools by selecting the Project menu or right-click the solution, and then selecting "Retarget solution".

I've searched for this error online and read that updating my Desktop Development with C++ Tools in VS2017 could fix the issue however it has not . I'm at a bit of a loss on how to proceed .

Just for reference I tried building in both Visual Studio 2017 and 2015 , the documentation I read mentioned wanting to build projects with 2015 ( due to IL2CPP compatibility I think) but regardless the project errors out regardless of which ecosystem I am building to .

Has anybody else encountered this error and might there be any advice on a solution ?


  • Is this a Unity project, or straight DirectX? If Unity, is there a reason you need to use IL2CPP?

  • Tis is a unity project and The build doesn't want to compile if I don't switch to an IL2CPP backend . It's the strangest thing, It seems to lose reference to some internal encryption libraries without IL2CPP . I have tried recompiling without it but the build fails almost immediately.

  • Ah, yeah. I've heard issues with using encryption. I've not messed with any of that at this point.

  • What type of encryption are you trying to use?

  • EvoxVREvoxVR
    edited September 2017

    I don't believe we're actively using any encryption but I do believe there is a mismatch between unitys internal .Net library and those officially released by Microsoft, I receive the following error following by additional errors when I try to build with .Net though

    : error CS0234: The type or namespace name 'X509Certificates' does not exist in the namespace 'System.Security.Cryptography' (are you missing an assembly reference?)

Sign In or Register to comment.