Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

[Solved] Sudden Trouble Building App / Metafile & First-pass.dll Missing?

edited May 2016 in Questions And Answers


The solution to this problem for me was to factory reset the hololens as well as my computer, and reinstall all software fresh. Also, don't forget to pair up your hololens before you attempt to build to it.

I know this solution is far from ideal - but if you need a quick fix, this is about as quick as I found.

Greetings holo devs,

I have followed the exact steps Microsoft lists under multiple projects within their Microsoft Holographic - Academy tutorials. I completed them all, and all of them worked just fine from creation to export and testing. This is using Unity3D / C# which gets compiled into a Visual Studio Solution (sln) file.

After completing those, I went on to build my own app - which built just fine as well. No problem!

Now when I try to build - I get a strange error that the c-Sharp.firstpass file (the exported/cross-compiled dll from what I understand) can not be found.

Now even the projects that built successfully won't build any more.

I will paste the exact error below.

Things I have tried:

  • Creating a new project and pasting all of the previous assets into it - then rebuilding.
  • Cleaning the VS project
  • Restarting my computer
  • Restarting Unity3D
  • Uninstalling and reinstalling Visual Studio (recommended version)
  • Uninstalling and reinstalling Unity3D (recommended version)
  • Following the tutorials step-by-step again
  • Searching StackOverflow and attempting every solution whose question remotely resembled my issue
  • Asking on Unity Answers (2 days ago)
  • Building the project file to different drives, folders, locations, etc.
  • To not give up
    There seems to be a referencing issue - so I have also unreferenced/referenced the mentioned file.

Thanks for any and all help



The error:

The command ""D:\Development\Hololens Builds\PlanetApp\Unity\Tools\SerializationWeaver\SerializationWeaver.exe" "D:\Development\Hololens Projects\Planetarium\UWP\Assembly-CSharp-firstpass\bin\x86\Release\Unprocessed\Assembly-CSharp-firstpass.dll" -pdb -verbose -unity-engine="D:\Development\Hololens Builds\PlanetApp\Planetarium\Unprocessed\UnityEngine.dll" -unity-networking=D:\Development\Hololens Builds\PlanetApp\Planetarium\Unprocessed\UnityEngine.Networking.dll "D:\Development\Hololens Projects\Planetarium\UWP\Assembly-CSharp-firstpass\obj\x86\Release\x86\Release"" exited with code 1. Assembly-CSharp-firstpass D:\Development\Hololens Projects\Planetarium\UWP\Assembly-CSharp-firstpass\Assembly-CSharp-firstpass.csproj 180
 Metadata file 'D:\Development\Hololens Projects\Planetarium\UWP\Assembly-CSharp-firstpass\bin\x86\Release\Assembly-CSharp-firstpass.dll' could not be found Assembly-CSharp D:\Development\Hololens Projects\Planetarium\UWP\Assembly-CSharp\CSC
Metadata file 'D:\Development\Hololens Projects\Planetarium\UWP\Assembly-CSharp\bin\x86\Release\Assembly-CSharp.dll' could not be found Planetarium D:\Development\Hololens Builds\PlanetApp\Planetarium\CSC


  • Jarrod1937Jarrod1937 ✭✭✭

    I had the same issue with my building yesterday. I searched for the dll in the main directory and then manually moved it to the x86/Release directory. Since I've been having so many issues with my install, I didn't want to report it as a bug, but it seems others have the same issue.

  • HoloSheepHoloSheep mod
    edited May 2016

    @Addyarb did you move all of your files under a new directory? I see that the path in your error message "D:\Development\Hololens Projects..." has a space in the path name between "Hololens" and "Projects".

    Unity does not deal with spaces in path name very well and in general does not deal with long path names well either so when organizing your Unity projects it is a good idea to keep short tight path names that are still descriptive enough to keep you organized.

    Also if you do move HoloLens Unity projects to new locations on your drive it is a good idea to delete all (or most) of the Unity build generate files and rebuild them at the new location.

    Here are a few of the files and folders that I recommend you clobber from the project directory and regenerate after a move if you run into any issues:

    Of course the one scenario you need to be extra careful is if you have added any extra UWP .NET 4.5 specific code files to your generated project. For those files you probably want to make backup copies before hand so that you can add them back in after regenerating.


    BTW you may have checked, but I didn't notice mention of installing Visual Studio Update 2 in your checklist of things you tried. For those who find this thread later, VS Update 2 is also required and can cause similar issues if it is missing.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • @Addyarb,
    This set of errors generally points to a project that has a very long path or spaces in one or more of the component names. SerializationWeaver.exe appears to have a limited path length it can support.

    Please try moving your project to a different location (ex: c:\projects), reload and build again.


  • Thank you everyone for the very thorough responses.

    Unfortunately, adjusting path name, moving drives/folders, and explicitly referencing (or trying to, at least) things within Visual Studio didn't help.

    However, after factory resetting the hololens, computer, and reinstalling everything fresh - I'm building just fine now.

    I wish I could've found the exact solution in order to further debug this for future users - but 2 days of the same bug was costing more time than it was worth.

    Thanks again, and happy developing!

  • So @Addyarb I am curious, after you reinstalling everything fresh did once again place your projects under a folder with a space in the name like:
    "D:\Development\Hololens Projects..."

    and if so, are you finding that all of your projects now work and load correctly?

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • @HoloSheep said:
    So @Addyarb I am curious, after you reinstalling everything fresh did once again place your projects under a folder with a space in the name like:
    "D:\Development\Hololens Projects..."

    and if so, are you finding that all of your projects now work and load correctly?

    Hi HoloSheep,

    Yes, I have been storing the VS builds on my desktop (C drive) and the Unity project itself on the D drive under Development/Hololens Projects...

    In theory (at least the way I understand it), the path of a project folder and it's respective build folder should be arbitrary since there are no references from one to the other. The build folder should contain the .dll and all assets necessary in order to build the project.

    I'm able to also build any other projects now - so my only thoughts are that this is a VS bug. Were that the case though, reinstalling it should've remedied that.

    As usual, the rare and stubborn bugs find me, and a couple days of good ol' fashioned fiddling around with settings/seemingly inconsequential things fixes it.

  • @Addyarb the fact that the path in question was referenced more than half a dozen times in your error message would make me think that this particular path in this case is probably not "arbitrary".

    Also I believe the SerializationWeaver.exe is a Unity tool.

    However, the tools are still beta and there are a lot of moving parts and a series of these kinds of bugs are still very common and occurring for a large number of users. So please don't feel singled out. :-) Besides seeing similar requests for help here on the forums, a number of us also spent a lot of time addressing similar setup issues at the beginning of our Holographic Hackathon event in Seattle.

    I have had first hand experience both in my own dev environment and at the hackathon when helping others where I observed a cause and effect relationship with simply removing the spaces or shortening the path name and seeing some of these errors go away.

    I am glad your individual issue is solved for now. I was curious about the use of spaces inside your path structure in your rebuilt environment because I feel it is important for us to understand the different combinations of causes and errors that we are seeing to both help others running into the problems and to find steps to repro the errors so that they can get fixed.

    So thank you for clarifying that you are now having success with the same path structure that includes spaces.

    For the sake of others working with these tools I would still recommend:

    • no spaces in path and file names
    • try to keep path and file name lengths short, concise but still informative
    • try to consistently follow the recommended project file structure and organization guidance of naming your build folder "App" and keeping it at the first level inside your unity project folder

    Also watch that you follow the latest tools installation instructions:

    Double check that you are building in for:

    As mentioned in thread above, delete and rebuild generated folders after moving or making significant changes to settings between builds.

    Those are some of the things that might help if you are running into build problems.

    Then there are similarly long list of issues with deployment.

    My favorite two tips there are:

    As a last resort the strategy of wiping and reinstalling everything might be necessary in some cases, but generally it shouldn't be necessary. A few quick searches here on the forums should find you some suggestions to try or post a new question and chances are someone else has already run into the same problem and will be happy to share and try and help troubleshoot your problem with you.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • ContextVRContextVR ✭✭✭

    We hit this issue at the HoloHack last week, and the solution was to move the project to d:\hololens, instead of keeping it in the user Documents folder. This resulted in a much shorter path, and project file related errors went away.

  • AlexDAlexD ✭✭✭

    I can confirm. Make sure you host your code and generated VS solution in a folder whose path does not contain any spaces and is relatively short.

  • Also confirm, Saw this Serialization Weaver problem as well when I had space in project name..

  • @HoloSheep (and the rest of the thread)

    So I ended up hitting this issue again when I named my project (in Build Settings) a name like "My App" instead of "MyApp."

    Immediately after seeing this error, I removed the space in my project name and rebuilt. The same error occurred.

    After that, I went back into the project. My thoughts were that this path name that I created had permanently affected the project to a point where it is irreversible. I deleted the project folder that Unity/VisualStudio had generated (not the actual project folder, the one that is created when you click the 'Build' button) and then created a new (password protected) certificate. I created this certificate by:

    1. Click File
    2. Click "Build Settings"
    3. Look under "Publishing Settings"
    4. Look under "Packaging"
    5. Click "Create"
    6. Enter the name and password fields
    7. Click "Create"

    After deleting the build folder and generating a new certificate, I rebuilt and did not encounter the aforementioned error(s). I'm not sure what the certificate has to do with it, but it's what helped me.

    I'd like to think that my error was much more severe - but perhaps this was my problem all along. An error regarding spaces in the file path - or even a bit of code that removes said spaces would be very helpful if they cause such a vague and show-stopping error. Other windows apps (that I see on the hololens) have spaces in their application's names, which is very confusing.

    Also please note, that the reason I deleted the project was because when renaming your existing project and rebuilding to the same folder (from Unity), you get a new .sln file which seem to break references left and right. At the very least, it doesn't properly overwrite your existing .sln file.

  • @addyarb as you have discovered the error is reversible, but again I would like to clarify.

    As described in my original correct answer to your question there are a number of files that Unity generates. Included in those generated files (as highlighted) is a solution file and a project file that after you change previously used paths (like when you remove spaces or shorten path names) you should delete and regenerate.

    Don't worry or mess with the certificate, it is not what helped you.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • @HoloSheep

    Thank you for the clarification. Your answer is definitely a solution for most, if not all instances of this error - including the one that I was able to replicate by changing the name. However, this still doesn't explain why projects that built just fine would suddenly be unable to build. I had taken all of the steps you mentioned in your answer with no results before resetting everything as I mentioned.

    Since I can't replicate that particular instance, I would say that you have lain out a very comprehensive check-list that I totally recommend for anyone finding themselves with this error.

    The certificate bit was pure speculation/trail and error. Sounds like it wasn't a factor after all - but I didn't want to leave it out just in case.

    Thanks very much for taking the time to reply and help me (and inevitably others) get a good idea of what this error means and how to troubleshoot it.

  • edited December 2016

    this work for me

    1 change the root path to D

    2 Change the build name short and works for me thanks to all of you

  • Followed all above directions and I'm still seeing this problem. Any new or better advice beyond @Addyarb's solution of reinstalling OS, tools, etc.?

  • edited January 2017

    I have the same Problem aswell.

    • Short Path Name
    • No Spaces
    • all the correct Build Plattform and Player Settings

    It is no Option for me to set up my whole System from scratch again. Earlier that Day i had a working build (before i really ran into the Problem) from a test Project. But if I try to build it again (with the same settings that worked before) now, it just does´nt do the job. I have no idea what went wrong, hope someone finds a tolerable solution to this.

    Edit: Even Building from an Empty Project only with one Cube and a Camera did´nt work

  • Additional Info: I have tried building my Project on another Computer. And it worked...for like 5 or 6 builds until it broke and showed the same Errors again. Now I am unable to build on 2 Computers. I really have no idea what I should do now

  • I'm getting this issue with a fresh build with basically nothing in it. I've read it could be a compatibility issue with VS, so attempting to revert or install a previous version. Other than that, how do you regenerate those files that you delete? They simple remained gone for me, even upon rebooting the project or building and whatnot.

  • Same problem here. Have tried a numder of solutions and those suggested above but still nothing...Has enayone found a different solution?

Sign In or Register to comment.