Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

I followed a hololence tutorial but I cant see any cube

I run the application in the emulator, I do not see the cube. All I see is a very small white dot in the middle of the view. The dot seems to move as I press the arrow keys on my keyboard and then it snaps back to the middle.

I am using VS 2017 version 15.3. I have the Windows 10 SDK v10.0.14393.795 and WIndows 10 SDK v10.0.15063.468 installed along with their respective Mobile Emulator for Windows 10. I have the HoloLens Holographic Emulator and templates v10.0.14393.1358 installed.

I am using Unity 2017.2.0b7 because of issues with 2017.1 and VS 2017.

I have followed the Holograms 100 process and I can see the cube in the Game view. I even added a material to the project and placed it on the cube to color it red. The cube Transform is as follows;

Position: x:0, Y:0, Z:2
Rotation: X:45, Y:45, Z:45
Scale: X:.25, Y:.25, Z:.25

I even tried setting scale back to 1 for x, y and z.

The solution builds in VS2017 with no errors or warnings. The project loads in the emulator with no errors or warnings.

Answers

  • james_ashleyjames_ashley ✭✭✭✭

    @dinukaw,

    That's pretty odd. It sounds like the Z for your cube is getting set extremely high in code somewhere. Can you drop another plain object in the scene with no scripts attached and see if it does the same thing?

    James

    James Ashley
    VS 2017 v5.3.3, Unity 2017.3.0f3, MRTK 2017.1.2, W10 17063
    Microsoft MVP, Freelance HoloLens/MR Developer
    www.imaginativeuniversal.com

  • According to your image the cube is at 0,0,7

    AR Developer

  • That's because of Visual Studio debugging. Run it without Debug.

Sign In or Register to comment.