Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Holograms 101 Spatial Mapping

I am running into an issue in the spatial mapping section of the tutorial. Everything works perfectly fine until I add the spatial mapping asset to the scene. When I run the app, the origami collection appears for a second with no spatial mapping meshes, and then the origami collection disappears. All that is left is the spatial mapping mesh of the environment and the gaze cursor. Does anyone else have the same problem and know of a solution?

I am using Unity 2017.1.1f1.

Best Answer

  • wanglabwanglab
    Accepted Answer

    Resolved.

    Change the Render State setting for the Spatial Mapping Renderer to Visualization.

Answers

  • james_ashleyjames_ashley ✭✭✭✭

    @wanglab,

    The origami collection is likely falling from it's initial location and falling through the floor before the mesh is completed (that would be my guess). To test this, turn gravity off on your collection and see what happens.

    James

    James Ashley
    VS 2017 v5.3.3, Unity 2017.3.0f3, MRTK 2017.1.2, W10 17063
    Microsoft MVP, Freelance HoloLens/MR Developer
    www.imaginativeuniversal.com

  • @james_ashley,

    Thanks for the response. The origami collection does not have a rigid body component and thus has no option to turn gravity on or off. Also it did not have this behavior before I added the spatial mapping.

  • wanglabwanglab
    Accepted Answer

    Resolved.

    Change the Render State setting for the Spatial Mapping Renderer to Visualization.

  • james_ashleyjames_ashley ✭✭✭✭

    Good job.

    James Ashley
    VS 2017 v5.3.3, Unity 2017.3.0f3, MRTK 2017.1.2, W10 17063
    Microsoft MVP, Freelance HoloLens/MR Developer
    www.imaginativeuniversal.com

Sign In or Register to comment.