Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Spectator View - How to get the camera feed in compositor?

Hey Folks,
I've got almost everything working following the guidance: https://github.com/Microsoft/MixedRealityCompanionKit/tree/master/SpectatorView

Calibration is good, got the camera feed from that, the problem I'm having is the compositor is not getting the camera feed. Before building the compositor and copying the dlls, I also installed the DirectXTK, cpprest, so everything seems to be fine. Then I run the copydll.cmd.

Everytime I open the project in unity, it would spam like this.

I think it's kind of a harmless error(If not, plz tell me).
Then I deploy the appx to my hololens, everything still goes well.

When I click play, I can see the hologram react well in unity window, but the camera feed in compositor remains blank. If I try to take a video on the compositor, the video will have the same problem. However if I take a picture, the hologram and the background show up - but only when I take a picture.
The picture is perfect

And the unity scene looks like this

I'm sure my camera is not used by other apps.

Did anyone have any clue for me? I'm really helpless > <

Best Answer

Answers

Sign In or Register to comment.