Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

MR Controllers not correctly named, refuse Bluetooth connection

Both controllers show up in the Bluetooth device list as "Input (Input)", and they are seen as game controllers. My phone interestingly sees them both correct with their "Left" and "Right" names. The PC refuses to connect ("device doesn't reply") and the full MR headset setup process does also not find the controllers (surely because the names are detected wrongly).
The headset otherwise works fine (tracking/visuals).

I tried everything suggested in Troubleshooting so far:
- reset controllers to factory
- update bt drivers (it's a Qualcomm onboard)
- restart & wait & restart etc.
- bt troubleshooting
- the Troubleshooting Controllers flowchart unfortunately doesn't show what "Step A.. H" are.
- full MR uninstall and reinstall

Any ideas?


  • Hi Herbst,

    My name is Yang and I'm an engineer working on Mixed Reality at Microsoft. There's a known issue with the Qualcomm Bluetooth controller that requires turning off your PC and turning it back on. Afterwards, you should be able to pair without issues.

    If you still run into problems, consider purchasing a USB Bluetooth Adapter as mentioned in the Windows MR Bluetooth best practices documentation.


  • Hi Yang,

    I have of course restarted the computer multiple times, unfortunately that didn't change the behaviour.

    I did get the controllers to work using a USB Bluetooth Adapter. I would still like to see the original issue resolved, but I guess then it is more a question about "how to fully reset the bluetooth stack", which I tried by uninstalling/installing the drivers, which also didn't work unfortunately.

  • MetathiasMetathias
    edited November 2017

    After a frustrating 4 hours of restarting, and reseting everything from drivers, to a hodgepodge of bluetooth related device profiles. No solution exists. That i can find that will make my bluetooth adaptor re-pair with the controllers. Possibly short of a total system wipe. Obviously these variables must be somewhere. But alas i have'nt been able to find them...I have to say. The whole.. "Go buy a new bluetooth adaptor" suggestion is pretty shotty. Seeing as how the motherboard my bluetooth (Qualcom Atheros QCA61x4A Bluetooth 4.1) is integrated into is a brand new X399 motherboard. And really should'nt require me going out and spending an extra 20 bucks or 30 bucks just to get a bluetooth dongle thats inferior to the one in my machine.. Just because thats the one microsofts engineers took the time to get to work.

  • I would like to echo this issue. I am experiencing the same thing. I have been happily running my HMD odyssey for over a week, and suddenly, I encounter the same issue. I have tried all the remedies short of a full system wipe. Please, lets see MS issue a fix!

  • The fact that Microsoft has remained silent on this is unacceptable. I did a full system recovery and had the controllers working again for 2 weeks. Yesterday the issue occurred again, so I did another recovery, but this time to no avail. I may at this point return the Odyssey and opt for a vive or rift.

  • Hi everyone,

    Thought I would throw in my 2 cents after having this problem. Controllers are now working again.

    I too went deep on this. Was almost going to wipe everything. I have a laptop with the Qualcomm Atheros QCA61x4 internal bluetooth. I have heard of other people having problems with Windows 10 and this bluetooth adapter when connecting other devices. I was attempting to fix last night but was not able to find a solution until this morning.

    My issue started after connecting another bluetooth device (PS4 controller). I lost connection to the Motion Controllers, tried to remove and re-add, only to see the devices listed as "Input" that can't ever successfully connect.

    I remember hearing that how windows 10 shuts down and restarts is different from previous OS and this may be why controllers which are paired and lost are still lost after a restart or shutdown. Maybe something is being held onto with all this quick shutdown and restart that Windows 10 does?

    **- I did a reset on the controllers (power off, hold bluetooth sync and power for 5 seconds, let go at same time)

    • I boot into my other OS (Server 2016 but that shouldn't matter)
    • I powered off then boot back into Win 10
    • Controller returned with proper naming when attempting to sync and sync was successful**

    I can't think of why this worked when it did besides that I went into the other OS. So, we could try to confirm this is not fully resetting by avoiding fast-start and doing a full shutdown, not a hybrid shutdown:

    • Start Command Prompt
    • type shutdown /s

    Would be interested to hear if this is a "solution" to the issue for anyone else.

  • I ended up returning my unit. Shame that Microsoft could not provide support. I will be buying the Vive Pro once available. Good luck everyone else with this issue!

  • I have the same issue and tried everything like everyone else here short of buying a bluetooth dongle.
    I just tried the "full" shutdown /r command to see if just rebooting was not resetting whatever needed to be reset but sadly this didn't work either.
    I am tempted to do a Windows Refresh but I don't feel like reinstalling all 40 VR apps/games I have on here :-/. I guess an overnighted BT dongle is my next step unless MS can figure out this most likely insanely easy to figure out problem.

  • Having the same issue, tried everthing already, deleting drivers , cleaning bluetooth registry , reseting controller to the factory setings still the same says INPUT in devices, and can't connect to them, any ideas what should i do? I'm not looking forward to deleting my OS :(

  • Does it also say "INPUT" under Device Manager? Are you able to right click on it, go to properties, driver tab, update driver, browse my computer, let me pick, and select the proper device? If you grab the app for your particular headset, does it check the firmware on the controllers?

  • I'm not even able to connect them to see in Device Manager, its just refusing conenction, end up with ordering dongle, will see if its gonna help

  • I also have this issue, and boy have I been going through the gambit trying to resolve this! I've done everything but a full recovery on this one and it's not fixed my problem.

    I have to admit, this entire Mixed Reality experience has been quite awful, I can see why the Rift and Vive are getting the majority of development focus. Side note, the bluetooth dongle that is "recommended" does not work with my computer, so that's not even an option for me.

  • Made even a reset of PC , still didn't help, i don't know what to do now

  • "still the same says INPUT in devices" vs "I'm not even able to connect them to see in Device Manager". That's why I'm confused.

  • KlemiXKlemiX
    edited February 2018

    I'm able to see in bluetooth in option to Add a Device instead of Right or Left Controller its named as INPUT and i'm not able to connect to it.

  • Before going to bluetooth, please go to device manager and do "Show hidden devices" and make sure to remove the old controllers. There's some funny things that go on with the controllers/headset that I'm assuming MS is doing to make sure things don't see them as monitors or regular input devices. It won't hurt to try and clean up anything that might be sitting around(I had to do clear the old out of device manager when I repaired my controllers to my bosses notebook, they wouldn't work or pair again to mine until I removed the old from device manager). To be clear, you are using the Bluetooth section in the mixed reality portal and not the windows main Bluetooth pairing section, right?

  • A lot of Windows 10 users reported that their windows 10 bluetooth missing
    or disappear. There are multiple solutions to fix this problem.

    Method #1: You need to Boot your system in safe mode and then back into normal mode. Hope, after it, you will not see this problem again.

    Method# 2: You need to launch Run Application and write "services.msc" then check the Bluetooth service option. Set the startup type as “Automatic” and then click on Start button.
    Method # 3: You can fix this issue to Installing the Default Drivers.

  • Hey, I was just wondering how you guys used and connected the Bluetooth adapter with the mr controllers, I'm not got with this side of tech.
    In advance, Thanks.

Sign In or Register to comment.