USB drivers make Windows Mixed Reality Portal and Windows crash (BSOD)

Hi all,

I just received the Acer Mixed Reality Headset and I'm not able to make it work.
I updated Windows 10 to build 1709, no other updates available.

I launched the Mixed Reality Portal, I ran the specs checker. USB had a warning signal. I followed the instructions to uninstall USB drivers from other sources than Microsoft and restarted. I now have drivers only from Microsoft (ASMedia USB 3.1 eXtensible Host Controller - 1.10 (Microsoft) with driver version 10.0.16299.15 and Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft) with driver version 10.0.16299.15). Now all specs get a check.
When the portal asked, I plugged in the headset on a USB 3.1 and I get a blue screen after 2-3 secs, with the message "KERNEL_SECURITY_CHECK_FAILURE". I tried on the front USB 3.0, I got the same issue.
I've tried to run verifier.exe, nothing as changed. I've restarted many times, trying multiple USB ports, even 2.0, nothing is working.

Any ideas?

Best Answer

Answers

  • I disabled ASmedia drivers in the BIOS, and plugged the headset on the from USB3.0 port. The good news it that the PC does not crash, but the bad news is that the Mixed Reality Portal does not recognize the headset and I receive a "Something Went Wrong" error 2181038087-4.
    In the device manager I do see Mixed Reality Device and Hololens Sensors.

  • RdashPRdashP
    edited December 2017

    SAME issue with SAME natively installed WIN10pro (v10.0.16299 Build16299) USB 3.0 driver here.

    According to these instructions "Microsoft" is properly listed behind the "Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)" driver. Please refer to picture.

    I try too overcome the exclamation mark with 'USB' under the MR readiness test, but because of 'johdipo's issues with the "ASMedia USB 3.1 eXtensible Host Controller - 1.10 (Microsoft)", I don't dare to install this USB 3.1v1.10 version additionally/instead of the natively installed USB3.0v1.0 version.

    Even though my motherboard does also carry the ASMedia USB 3.1(gen2) controller beside Intel's own X299 USB 3.1 (gen1) controller chip.

    Why does WIN10 natively install a USB3.0 driver when both my USB controller-chips are USB3.1 spec?

    How to get rid of our USB compatibility issue with test and usage of HMD in MR portal?

    MR Developers, please advice!
    Thank you in advance.

    snapshot MR Portal Test results

    snapshot USB driver Device Manager

  • I have the same issue with same drivers under my WIN10 setup (WIN10pro v10.0.16299,Build16299): during the system compatibility test in the MR Portal, I get this exclamation mark (link) next to USB (non-)readiness.

    Even though I do see "microsoft" in the USB 3.0 drivername (link) WIN10 automatically installed, as instructed by the online MR support document (link).

    On my motherboard I also have the ASMedia USB 3.1(gen2) controllerchip, beside Intel's own integrated X299 chipset USB3.1(gen1) controller.

    Because of the BSOD issues 'johdipo' is facing, I don't dare to install the corresponding "ASMedia USB 3.1 eXtensible Host Controller - 1.10 (Microsoft)" driver beside/ instead of the by WIN10 already automatically installed "Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)" driver!

    Why does WIN10 automatically install an USB 3.0 driver, when both my USB controller-chips are 3.1 spec?!

    How can 'johdipo', myself and probably many others overcome the by this MR portal claimed USB incompatibility?

    MR Developers please advice a/o debug this USB compatibility issue.
    Thank you in advance.

  • RdashPRdashP
    edited December 2017

    buggy site its duplicate post removed

  • RdashPRdashP
    edited December 2017

    On second look in my Device Manager its USB driver list the "ASMedia USB3.1 eXtensible Host Controller" is also already installed but without "microsoft" at the end (link)!

    Both USB drivers are digitally signed by Microsoft as snapshots of both my driver details show. Therefore we can expect them to be compatible, also with MR-HMD headsets...

    Which of both "eXtensible Host Controller" drivers will support our MR-HMD properly then?

    Please advice.

  • Or should we manually install the "ASMedia USB 3.1 eXtensible Host Controller - 1.10 (Microsoft)" instead of the currently automatically installed ""ASMedia USB3.1 eXtensible Host Controller" for this device?

    Why isn't WIN10 automatically installing this "ASMedia USB 3.1 eXtensible Host Controller - 1.10 (Microsoft)" instead of the current incompatible(?) ASMedia driver?
    Do we have to wait until Microsoft digitally signs the "ASMedia USB 3.1 eXtensible Host Controller - 1.10 (Microsoft)" driver?

  • I am wondering the same thing. I have a similar problem but in my case windows automatically installed Etron USB 3.0 eXtensible Host Controller 1.0 (Microsoft) and not the one from Asmedia.

  • Interesting to see that other people experience the same issue. Have you been able to solve it?

    More help from Microsoft would be nice as well.

  • I'm experiencing the same or very similar issues with my Samsung HMD and it seems there were similar ASUS USB issues with the Oculus. Any input from Microsoft would be appreciated.

  • All,

    Please both file feedback to the Mixed Reality category via Feedback Hub.
    This will get us some logs to dig into. The Microsoft driver is our recommended path as we've found a number of compatibility issues with 3rd party USB stacks.

    In your feedback, feel free to link back to this thread so that we can link up.

    Thanks,
    BenP - From Microsoft

  • I'm having the same issue on my girlfriend computer, BSOD One time but most of the time Steamvr crash then Portal won't detect the headset unless I restart and plug the usb3 on another slot OR i found out i could uninstall those USB3 driver and have them reinstalled instead of restarting. I'm having none of those issues on MY computer... Help

  • I'm having the same issue on my girlfriend computer, BSOD One time but most of the time Steamvr crash then Portal won't detect the headset unless I restart and plug the usb3 on another slot OR i found out i could uninstall those USB3 driver and have them reinstalled instead of restarting. I'm having none of those issues on MY computer... Help

  • @aireland said:
    I was having the same problem. Plugged in my Windows Mixed Reality headset and got the BSOD. Tried everything, nothing worked. This is what I did to get it to work. I have a ASUS motherboard. I uninstalled ASUS AI Suite 3, and now everything works fine. Hope this helps.

    That was it! Thanks for your solution, hoping it will help others.

  • Help!! I was having the exact problem as johdipo and aireland with the same USB warning and exact same BSOD (KERNEL_SECURITY_CHECK_FAILURE), and I also have an ASUS motherboard with ai suite 3 installed

    Only difference is I've uninstalled ai suite 3 and I'm STILL crashing.
    This time it's "IRQL_NOT_LESS_OR_EQUAL" and it points to AndroidAFDx64.sys.

    Apparently this file is from ai suite, which is strange considering I've already uninstalled it.
    I searched and found the file but I couldn't delete it. I renamed it to .old but that disables my USB driver (which was really difficult to get back to windows!)

    I'm starting to run out of ideas and is considering sending it back. Please help!

Sign In or Register to comment.