Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Mixed Reality will not recognize my USB 3.0 or 3.1 ports.

I just built out a new PC with an ASUS TUF Gaming Z370-Plus motherboard with 8th Gen i7 and EVGA GTX 1080. It has two 3.1 USB ports two USB 3.0 and a USB type C. But Microsoft is telling me that I don't have any USB3.0+ ports even before I hook up my Dell Visor. Anyone seen this before? I am including an image of my drivers and the screen showing what I am missing. The USB 3 ports all work with other USB 3 devices.

Best Answer

Answers

  • I think you are correct. I found something a little while ago that said Click any driver that includes the words eXtensible Host and doesn't also mention Microsoft and remove it and get the Microsoft one. I took a short cut and noticed that the 3.0 was Microsoft and the 3.1 was not. By changing the visor to the 3.0 plug it now works. I guess I replaced that one but did not change the headset yesterday. It is working now. I will get them both changed to Microsoft soon. Thanks for looking at this.

  • FimFim
    edited March 2018

    Hee guys, I have the same issue here. Brought a new lenovo mixed reality headset, Connected it to my msi x170a motherboard with usb3,1 intergrated on the board. Did al the checks, reinstalled al the drives. Nothing seems like to work. Afther I disabled the ASMedia USB3.1 eXtensible Host Controller (Msi not authorized by windows) then it recronized the 3.0 port but next page, in the installation, it is stuk again at "Welcome to Windows Mixed Reality, Connect your headset".

  • Hi guys,

    had the same issue and finally found the solution to this, which is really not
    perfectly documented by Microsoft... This could use some work.

    Ok, so for my ASmedia USB 3.0 extensible Hostcontroller the solution was going into the devicemanager, right-clicking the device, and choosing "update driver". In the pop-up window you want to click "Search driver on PC" (not sure if it is named like that, because I have another language set up) and on the next screen you should select "Choose driver from list".
    There you might have the microsoft driver. That was easy. After doing this and making sure USB-3.0 legacy support was disabled in the BIOS, my Acer AH is working again.

    Best

    caos

  • Ah, looks like my link from Jan 15th that explains what caos did doesn't exist anymore(thanks MS!). https://docs.microsoft.com/en-us/windows/mixed-reality/enthusiast-guide/troubleshooting-windows-mixed-reality and go down to "I'm getting a "Something Went Wrong" error code" and look at 2181038087-12

  • I have had issues with the USB 3.0 ports as well, I have a HP Mixed Reality Headset that worked fine up until a few months ago, I haven't been able to get it to work even thought I get all the ticks in the Mixed Reality Portal, it now tells me to check if it is plugged into a Superspeed USB 3.0 port, which it is!
    and the Device Manager indicates for the Mixed Reality devices that there is insufficient USB Device Speed : 2
    even though the Device Manager indicates for the Universal Serial Bus devices that it is working properly, also noticed that the connector at the headset gets really hot.

    My motherboard is an MSI X399 Gaming Pro Carbon AC, so the spec's are good, wondering if there has been an update that's causing this issue, getting terribly frustrated, please help.

  • wish i could help but i got the same problem,you would think they would test these headsets

  • same problem here

    Any solution to this? It worked for months, then I get the same issue as everyone above

  • Hello everyone, after 6 months using my WMR acer without any problem, this has happened to me, that although everything is fine, I no longer recognize my headphones, I have done everything I've read in this thread but I have not had luck, I still can not use my Acer, any solution to this problem ?, thanks

  • I've had the same issue. First the headset worked, though with flickering from time to time in one screen at the time. later I got black screens for shorter periods. My system is fine 8700 i7, 2080ti, 32 RAM, USB 3.0 and 3.1 gen 2, but after some days of use I got the same USB issue mentioned above. I did all the USB driver updates, tested that USB ports worked on other usb devices, reinstalled WMR etc. sometimes I get "Hololens" in device manger, some times the PC recognises my HP Reverb VR. I've come to think that the weak link of the chain could be a weak connection between the headset and the cable from the PC. Too many turned of the heads might be too much for it? Sadly on my Reverb it lasted less than a week. From what I read online Reverb currently has that issue, but a fix in next batches should be on the way. It might be that other headsets mentioned here have the same issue, just that it takes longer untill it occurs?

Sign In or Register to comment.