Shaking holograms with Vuforia

Hi everyone!

I am carrying out a project in which I have had to install Vuforia to detect objects. The problem that I am having is that the holograms vibrate with the movement of the head. Apart from this, if the movement of the head is serious, the HoloLens displays the following text: "Trying to map your surroundings". When it occurs, you need to restart the app so that it works.

Before that I used Vuforia, the app worked well, that is, the things that I mentioned before did not happen. I think that the configuration of Vuforia is good because I followed the documentation to install Vuforia with HoloLens.

The following images show the configuration that I have in my project so that someone can help me to solve my problem. I have to say that the version of unity and vuforia is 2017.2.1f1 and 6.5.25 respectively.

ARCamera

Vuforia configuration

Image target

Hierarchy

Settings

In publishing settings, the capabilities selected are: spatial perception, microphone, webcam and internetClient.

Thanks in advance,
Cristian.

Tagged:

Answers

  • @CristianGómez Does your app have a world anchor in it? Or are there a lot of world anchors? I find that not having a world anchor or having too many can cause a lot of shaking for Holograms in my applications. I could also be that you are doing a lot of processes at once and the HoloLens is having trouble keeping up. Run the application and check out the app's FPS and see if it is taking a big hit. You might have to turn off some other processes while you are using Vuforia.

    AR Developer

  • Hi @dbarrett I do not have a world anchor in my app. I am new with HoloLens and I do not know the purpose of the world anchor. Do you think it could solve my problem?

  • You could try it and it might work otherwise it could just be a big process that is taking up a lot of memory.

    Anchors are used to mitigate the shaking and drifting of Holograms in applications as you move around especially if you are moving around a lot in an application. Check out Microsoft's documentation over world anchors.

    https://developer.microsoft.com/en-us/windows/mixed-reality/spatial_anchors

    AR Developer

  • @dbarrett I have solved the problem. The version of unity that I am using does not work correctly. I have changed to 2017.2.0f3 version and everything works well. I have not changed anything, I have used the same project with the version that I have downloaded.

    Thank you for trying to help me.

  • For the total noob, like myself, who ends up on this page, I deployed my app as Release instead of Debug and my FPS went from 23 to 60. Naturally, all the shakiness disappeared after that.

  • I deployed the solution as Release too, but the shakiness did not disappear. Now I am using Unity 2017.2.1p1 as recommended and I have the same problem again. Do you use this versión? @climbcodecreate

  • Hi,

    I am also facing same issue. If anyone have a solution to resolved this issue then Please help me.

Sign In or Register to comment.