Offline Installation

How do we Install mixed reality offline? I believe I saw an installer for it but I cannot find it. Our company just bought 10 Samsung Odyssey headsets, but we work in an air-gapped environment. We can update our computers fine with disks, but the mixed reality thing is a serious pain. Is there a directory I can copy and paste onto these computers? That's how we use steam. Update steam on one computer that's not air-gapped, and copy and paste the whole steam directory and it works great, but unfortunately, I cannot find the mixed reality directory.

Answers

  • JayZuoJayZuo mod
    edited January 31

    You can try to manually install the Mixed Reality software with following steps:

    For more information, please see Enable or block Windows Mixed Reality apps in the enterprise.

  • Hi Mikenspired,

    My name is Geoff, and I'm an engineer working on the Windows Mixed Reality team at Microsoft.

    Crossposting my reply from Reddit here for anyone else interested. This is an untested scenario, but an offline-only install should work. There are a few components you'll need to manually install:

    1. Please make sure you're on the latest version of Windows 10 Version 1709 (the Fall Creator's Update, Build 16299.192+)

    2. The Mixed Reality software (a.k.a. the Feature on Demand) package - please see this page (under "Manually install the Mixed Reality software") on how to download and install this package manually: https://docs.microsoft.com/en-us/windows/application-management/manage-windows-mixed-reality

    3. The Mixed Reality headset driver - you can download and install the latest driver here: https://www.microsoft.com/en-us/download/details.aspx?id=56332

    4. The Mixed Reality motion controller model driver (to enable the 3D models in SteamVR) - you can download and install the two drivers located here: https://www.microsoft.com/en-us/download/details.aspx?id=56414

    5. SteamVR and the Windows Mixed Reality for SteamVR component - unfortunately I can't speak on any guidance regarding SteamVR offline installs.

    Please also make sure you have the latest graphics driver from AMD.com or Nvidia.com, as those are constantly being updated with improvements and fixes.

    Thanks!

  • I think I completed the steps you mentioned, but when I open up windows mixed reality it still tries to go through setup and says no internet connection.

  • We've got the same problem with offline computers at our company too. Downloading and installing the mixed reality features via .cab files works fine, but in the Mixed Reality Portal setup wizard, there are hard blocks which check for internet connectivity. To reproduce this:

    1. Remove the Mixed Reality package
    2. Reinstall
    3. Disconnect from the internet
    4. Launch the Mixed Reality Portal
    5. Attempt to complete the wizard

    I booted up Wireshark to see if any external requests were being made, but it didn't look like there was any traffic. I suspect the application is using something like the Network List Manager to check against the Network Connection Status Icon for external network connectivity to avoid the internet loading circle of doom. There is some evidence to support this because when I spoofed the dns.mfstncsi.com DNS server and www.msftconnecttest.com HTTP server (according to the blog linked above) I was able to convince the NCSI test that I was connected and completed the Mixed Reality Portal setup wizard successfully.

    Unfortunately, my workaround only worked on Windows 10 Home Edition and when I tried to recreate my steps on Windows 10 Enterprise I couldn't convince the NCSI test it was connected (I'm guessing an anti-virus program was giving me away? I did check the group policies...).

    I think your solution will eventually work, but we're blocked by the NLM checks. Any chance you could remove those checks in a future update (or branch)? Or do you have any other recommendations?

  • @Gelo said:
    …..

    Is there any Update on this?

    I have gone to 1803 Build 17134.5 - Now the Downloading in Mixed Portal doesn't even start - it stops straight after the setup (before it at least pretended to download to 100%. Is the Back End for this down?

    I have this Issue and it seems to be there to stay - following your guide I could get the Portal Software to run, but it screws the Updates for 1709 and portal software still does not work. It cant start up, no mater if real or simulated hmd in developer mode. Cross Talking I was pointed out that OneCore Dev cab FOD could be missing.

    I also posted here:
    https://forums.hololens.com/discussion/7448/we-couldnt-download-the-windows-mixed-reality-software?

Sign In or Register to comment.