Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Testing Sharing service with only one hololens

hello,
I develop hololens application with sharing service.But,I have only one hololens.

I try to test my sharing service with hololens and emulaor. First I run my application in hololens without debug mode.then I run it in holographic emulator.It join the session which created by hololens. But after it immediately leave the session.

So,Can you help me to test sharing service with only one hololens?

Answers

  • Are you using Unity? You could try to join from Unity and see what the logs say (or add more) to figure out why it is leaving the session.

    Taqtile

  • edited February 2018

    Thanks @mark_grossnickle,
    I try it unity but there are access denied error at following section:
    " if (status == SerializationCompletionReason.Succeeded && wat.GetAllIds().Length > 0)" I also try to run my unity as an administrator but no any change.
    I also try to put import anchor process state into textbox ,run it in emulator and it shows the state is "Currentstate: Ready".

  • In Unity do you have the build targetting UWP?

    What file and line number is that?

    What version of Unity and version of HoloToolkit are you using?

    Taqtile

  • @mark_grossnickle ,
    Yes,I have build targeting UWP.

    I get error in "ImportExportAnchorManager.cs" and line number 478 (if (status == SerializationCompletionReason.Succeeded && wat.GetAllIds().Length > 0)).

    I am using "Unity 2017.2.0f3-MRTP (64-bit)" and HoloToolkit which are using in hololens academy hologram 240.

  • Oh, did you add SpatialPerception in Player Settings under Capabilities? You also can add it by going to Mixed Reality Toolkit's drop down menu in Unity and then Configure and Capabilities.

    Taqtile

  • edited February 2018

    Yes, i already add SpatialPerception in Player Settings under Capabilities.

  • I just checked my ImportExportAnchorManager and the line you are referring to does not exist. I also checked the latest on github and do not see it there either:
    https://github.com/Microsoft/MixedRealityToolkit-Unity/blob/bce6505ec2f57b5dbed7b63d31a6d46d0d96bcc5/Assets/HoloToolkit-Examples/Sharing/SharingService/Scripts/ImportExportAnchorManager.cs

    Perhaps update to the latest HoloToolkit?

    Also, is the error happening just in the emulator? I'm guessing anchors would not work in the emulator... just the device.

    If you want to test between device and the Unity Editor or emulator you'll need to ignore anchors in the non-hololens device.

    Taqtile

Sign In or Register to comment.