Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Samsung Odyssey issues with Wpnuserservice, and SteamVR, HELP

This is verbose to make everything clear....if "tl:dr" then simply no need to respond.

SO I have had quite a few headaches with the Samsung Odyessey, which I really want to like, screen is nice, looks good, feels solid, and the controllers seem better then Oculus or Vive......but man this has been a pain.

I had recently upgraded to Windows 10 from 7 when my prior ssd crashed, and it has been running flawlessly for several weeks. I have played all sorts of games without issue.

My system:
i7 3770k 2nd gen 1155 socket
Asus P8H67 M EVO motherboard
16 GB RAM
EVGA GeForce GTX 970 4GB SSC Gaming ACX 2.0+ Cooling Graphics Card (04G-P4-3975-KR)
Samsung 850 Pro 512gb SSD
I have an insignia USB 3.0 PCIe board, and a Blutooth plugin

When I first got the Odyssey, i hooked it up but the 3.0 usb on my motherboard it did not like and it would not work.....ALSO on rebooting Windows 10, I received the dreaded "Task Host Window stopping background tasks \Microsoft]Windows\Plug and Play\Device Install Reboot required". message some got after 1709 update.
Then the startmenu failed to open nor would cortana search or most stuff on toolbar work.....the only fix I found to work was to regedit and change wpnuserservice from a start 2 to 4 value.....a fix people used in past for that issue, it's not a real fix though it turns push notifications off thus breaking many things like.....all windows mixed reality headsets.

I got the above usb 3.0 daughterboard and windows recognized the Odyssey but then it would black out while loading cliffhouse....I finally decided my user/admin acct was corrupt and just reinstalled windows 10, this time with the USB 3.0 card and everything installed I loaded up SteamVR and it worked!everything was good other then being choppy, i played around ins tart area customized avatar etc......so I decided to reboot....and guess what?

Windows 10 gave me the "Task Host Window stopping background tasks \Microsoft]Windows\Plug and Play\Device Install Reboot required". error message AGAIN, and my start menu died again...I ended up on phone with Samsung who blamed Microsoft and could not help me (or even try) I then called Microsoft and a tech tried everything he could via remote access to fix it, (I am unsure what he all did) finally I just did the disable wpnuserservice trick again and fixed menu, and MS technicians decided it was all fixed. He did his best but had to refer me to lvl 2 tech for later but now samsung would not work again. Still waiting for scheduled appt with a level 2 MS technician which apparently is like making a drs appt.

In desperation I turned wpnuserservice back to 2 in regedit and rebooted but purposely did NOT touch start menu or anything just tried to run WMR, and it worked again! Great in fact cliff house, apps from MS store etc......and after awhile I checked startmenu and it was working again...no idea why. ( I say a prayer every time I reboot now)

The good news is Samsung on WMR cliffhouse etc works fine. Not really sure why but it is. each time I load up I avoid start menu until I have been running awhile though.

The bad news.....now SteamVR will not recognize it, i have uninstalled steam VR and WMR for SteamVR and reinstalled..but it does not matter I get the 301 error message....and nothing works. If I can not get steamVR working I may just have to return this set and wait for vive pro......I don't want the crusty reg VIVE that cost more with less funcionality then Odyssey......someone PLEASE HELP ME! It worked before so I know it's not my card, or hardware or it would not have worked the first time. I am stumped why it won't work now though.

I want to love the Odyssey, but if I can't do Steam VR games.....it is near pointless. If I can't fix this I will give up on WMR..

Answers

  • I really am at my wits end. I feel sure this is USB related. I used the program USBDeview to go through USB devices and one by one reload to try and see if it was conflicting, I have tried it with the Asus 3.0 drives and without....(I am not using the Asus 3.0 usb as it does not work with Samsung) I have tried everything I can think of now.

    The odyssey works great on its own, and cliff house, but STEAM VR simply can not see it, and I get the 301 error everytime. I would just give up on it and say it's my system, EXCEPT that IT DID WORK BEFORE! When I first did my fresh install and before the "Task Host Window stopping background tasks \Microsoft]Windows\Plug and Play\Device Install Reboot required".error message on reboot......it was working as steamvr ran fine.......I can not figure out WHY it will not see it now. DOes anyone have ideas I might try?

  • MRFanMRFan
    edited February 2018

    I'd suggest you do a clean re-install of your OS. It seems there is something wrong when you first upgraded to Windows 10.

Sign In or Register to comment.