Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Restoring NuGet packages taking long?

I am following the Holograms 100 tutorial, and I am in the step "Export Visual Studio solution", and I already clicked build on unity. Now it is in the process of building, but it seems to be stuck at "Restoring NuGet packages". I have been waiting for an hour now. Is it normal that it takes so long or am I missing something?

Thanks.

Answers

  • @mxxo, Having to wait for an hour is much too long for restoring NuGet packages.

    I would recommend closing and restarting Visual Studio. Then clean your solution (Build > Clean Solution) and rebuild.

    Thanks!
    David

  • @DavidKlineMS said:
    @mxxo, Having to wait for an hour is much too long for restoring NuGet packages.

    I would recommend closing and restarting Visual Studio. Then clean your solution (Build > Clean Solution) and rebuild.

    Thanks!
    David

    I am having same problem. Problem is not on Visual Studio but on Unity IDE. I am building on Unity so that I can run from Visual Studio. Could you please suggest some help?

  • I have same question! Build on Unity is failed to restore nuget package.
  • I ran into this yesterday myself and I was not sure what caused it. I tried checking for Visual Studio updates and there were none. Here are the things I realized and resolved, then the problem went away (for me anyway):

    1. Visual Studio was set to verbose logging. This isn't a problem, it was just adding to the length of time due to the number of log messages getting printed. I set it back to 'Normal'. Tools -> Options -> Projects and Solutions -> Build and Run -> MSBuild verbosity settings (two of them).
    2. The HoloLens was pending a system update. This shouldn't have caused any delay in the build portion but may have complicated things during the deployment portion.
    3. Visual Studio was just plain acting weird. When I did Build -> Clean I got an error about a missing file. I rebooted the machine and these VS issues went away.

    Again, your mileage may vary but this is what resolved it for me.

    Our Holographic world is here

    RoadToHolo.com      WikiHolo.net      @jbienz
    I work in Developer Experiences at Microsoft. My posts are based on my own experience and don't represent Microsoft or HoloLens.

  • I simply rebooted my machine and the problem went away. However, the build process still remains quite slow.

  • This happened to me as well. I cancelled the build, switched my Scripting Backend from .NET to IL2CPP then tried again and it worked. I'm not sure the Scripting Backend had anything to do with it though.

Sign In or Register to comment.