Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Hololens Universal10 build Json .Dll Error Solve

Hi All I'm Korean Delveloper

I have a solution for Universal10 build errors.

My Error Type is as follows.. ▼ :)

C: \ Users \ MyApp \ App \ HologramCube \ HologramCube.csproj (274,5): error MSB3073:
"C: \ Users \ MyApp \ App \ Unity \ Tools \ AssemblyConverter.exe" Command -
Platform = uap-lock = "C: \ Users \ MyApp \ App \ HologramCube \ project.lock.json"
-bits = 32 -configuration = Release -removeDebuggableAttribute = False -path = "." - path
= "C: \ Program Files \ Unity \ Editor \ Data \ PlaybackEngines \ MetroSupport \ Players \ UAP \ dotnet \ x86 \ Release"
"C: \ Users \ MyApp \ App \ HologramCube \ Assembly-CSharp.dll"
"C: \ Users \ MyApp \ App \ HologramCube \ Assembly-CSharp -Firstpass.dll"
"C: \ Users \ MyApp \ App \ HologramCube \ UnityEngine.dll"
"C: \ Users \ MyApp \ App \ HologramCube \ UnityEngine.UI.dll"
"C: \ Users \ MyApp \ App \ HologramCube \ UnityEngine.HoloLens.dll"
"C: \ Users \ MyApp \ App \ HologramCube \ UnityEngine.Networking.dll"
"C: \ Users \ MyApp \ App \ HologramCube \ UnityEngine.VR.dll" "
Ended with code 1.

There are three cases of this error.

1. Nuget cash has been initialized.

2. Unity Project Route is to long OR Short OR Unusable Characters(!@#$%^&*....etc).

3. Using the wrong build method.

First. Nuget Cash Error.

There are two solutions to the error.

1. DownGrade visual studio 2017 - > 2015 .

2. Manually change Windows 10 sdk.

But Downgrade is So Harrrrrd ! :p

Therefore, I recommend the second method.

The cause of this error is a problem with the Window SDK10 version.

  1. Click GeneratedProjects.

  1. Click 1,2 Folders. (This Folder is Check Unity Build Option Unity C# Project Option)

  1. Find project.lock.json And Open it In the Editor
    (if This file is null -> Build it in Visual Studio and exit. )

  1. Change Code "UAP,Version = v10.0xxxxxxx" -> "UAP,Version = v10.0"
    (This version is the version supported by Unity)

  2. 1,2 Folder is Make the same changes.

6.Return to Root Select Project Floder.

  1. It is the same things Change to project.lock.json
    ("UAP,Version = v10.0xxxxxxx" -> "UAP,Version = v10.0")

8.UWP Folder ->Change to project.lock.json
("UAP,Version = v10.0xxxxxxx" -> "UAP,Version = v10.0")

  1. Everything is done.!! :D

Second. Text Error.

is Checking Folder Name OR Whether there is unavailable text in the path Check.

This case is too easy. So I will not give a detailed explanation.

(Perhaps you have already tried this problem.) :*

Third. Using the wrong build method Error.

You must check. Microsoft Hololens documentation.


Microsoft always finds out... :|

This is all the solution I have found.

Please let me know if there is a better solution. Good Bye!


  • Note please. !!

    If this option is not checked, please follow the picture.

    Thank you:)

  • THANK YOU!!! <3 It finally helped after a few hours of searching what the problem was...

    The project.lock.json edits did the job

  • Thanks man! The first solution worked. :smile: I hope they'll fix this soon so we won't have to change 3 files everytime we want to build

  • thank you so much, you save my day, the first solution worked perfectly

  • uciicauciica
    edited October 2017

    I haven't tried this. But I have the same problem. error MSB3073 and all of them exited with code 1. I was using VS 2017 15.4.0 and Unity 5.6.0. I just upgrade the unity to 5.6.3p2, check the 2 NuGet to be allowed and voila! It works!

    p.s I hate how this MR works. You have to do trial and error many times about the software version, and if you're lucky just few times or not at all.

  • The first solution worked! This online tool is useful as well: JSON formatter

  • You are a hero! Thank you! This bug was causing a total work stoppage on my thesis, so you just saved me from failing out of University! <3

  • Thank you very much Sir, my build issue was related to the folder path being too long! Well done and all the best on your work!

Sign In or Register to comment.