Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Motion Controller Disappear after loading new Scene

Hello Developers,

Yesterday i received the Motion Controllers. All in all they work very well.
I tryed to integrate them in my existing Project which also worked quite well.

The problem i am facing is when i click a button to change my scene the motion controllers disappear. The input is still working but they are not visual any more.
Does anyone have an answer for that?

I would realy appreaciate that.

Thanks in advance.


  • I had this problem in the mixed reality portal itself. But now it works all time. I fixed the issue with a simple power off/on.

    French XR/MR developer / Indie Game Developer

  • BendrixBendrix
    edited October 2017

    thanks for the fast answer.

    Sadly this does not work in my case.
    In my first room everything is fine but after changing the scene to the next room the controllers disappear but the input works even after turning power on/off.

  • What do you use exactly? The MRTK or anything else?

    I use Unity and my own models for the controllers (it's a gun in a hand).

    French XR/MR developer / Indie Game Developer

  • BendrixBendrix
    edited October 2017

    I use Unity with the MRTK and the "Motion Controller Visualizer" script.

    When i open up my builded project in the Microsoft Room everything works fine.
    I can see the model of the controllers and they are also tracked the right way.

    I just dont get it if i hit the button in my own room with the Scene Loader Script on it everything still works fine only the model of the controllers are not visible anymore. (but the controllers where still tracked - i can see the cursor moving the correct way with the controller and can still hit buttons)

  • I don't use the MRTK but maybe @Jesse_McCulloch will know?

    French XR/MR developer / Indie Game Developer

  • There is a bug where the controller is removed/readded the first time you pull a trigger. The solution the MRTK came up with was to pay attention to OnInteractionSourceUpdated and load the controller model if we see a source ID we're not already tracking.

Sign In or Register to comment.