Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Acer AH100 Immersive headset not working on PC

I have the Acer AH100 immersive headset (development edition) and can't seem to get it to work on my computer. The MRP starts up and looks like it's detecting the headset, but seems to oscillate between starting up and turning off a few times before the MRP stays at "Connect your headset". In the headset display I can see the windows logo pop up a few times, but the displays then turn off, and this repeats maybe 3 or 4 times before the MRP kind of gives up on it. I purchased a separate powered USB 3.0 HUB to make sure that the USB was getting enough power to support the device, but still the same results. This headset does work on a different computer I have, but unfortunately that's not the one I need to develop on.

Here's the Mixed Reality PC check info

Also, in the Device Manager, under "Mixed Reality Devices > Acer AH100" there is a yellow exclamation icon on the device. In the "Properties > Device Status" it reads:

Windows has stopped this device because it has reported problems. (Code 43)

PoseThreadNoSensorDataFirmware. No sensor data in the last 5 seconds.
Received 4952 IMU samples and 440 camera samples.
Total 5140 IMU samples and 452 camera samples.
IMU: 0x00000000
UVC: 0x00000000

Wondering if someone has experienced the same issue or can help me narrow down the problem here. Thanks!


  • Also, knowing the computer and gpu specs you are trying to run on will help a lot with the troubleshooting

  • MS recommends plugging in the headset directly into the computer. Also there should be no need for a powered USB Hub, mine is working fine being plugged into PC directly. Also keep in Mind that USB is specified to work on a length of up to 5 Meters, so if your Hub is (for whatever reason) longer than 1m, this might be the problem

  • @wulkanat Thanks for those flow charts. On the first one I get to where it says to try the HMD on another machine, and it DOES work on another machine, so I don't think it's an issue with the HMD hardware. On the second chart I get to where it says to "Check for messages inside MR device". There IS a message in the device that says something is wrong, but I don't know where to troubleshoot from there. Here is that message:

    Windows has stopped this device because it has reported problems. (Code 43)

    PoseThreadNoSensorDataFirmware. No sensor data in the last 5 seconds.
    Received 4952 IMU samples and 440 camera samples.
    Total 5140 IMU samples and 452 camera samples.
    IMU: 0x00000000
    UVC: 0x00000000

    I only got the USB 3.0 powered HUB to see if USB power was the problem, but since I received the same results with it I have gone back to plugging the HMD directly into my PC with both the HDMI and USB cables.

    @Jesse_McCulloch Oh, is the image not visible in my post? Or are there more specs I can provide besides those that will help?

    CPU: Intel Core i5-2500K @ 3.3GHz
    GPU: Nvidia GeForce GTX 970
    Graphics Driver: (WDDM 2.3)
    RAM: 16GB
    USB 3.0+
    Windows 10 Pro Version: 1709
    OS Build: 16299.19

  • So knowing the Error message I would say it is either a problem with a bad USB Port. have you tried plugging in a normal USB 3.0 (!) Stick/Device? So what the message is basiacally saying is that the PC is receiving less packages of data from HMD than expected, meaning there has been data loss...

  • @Fat_Bastard Thanks, it does seem similar, but not exactly what I'm seeing. I'll keep an eye on that issue too just in case.

    @wulkanat Thanks for the info! I have plugged in other USB 2.0 devices into that port and they've worked fine, not sure if I have any other specifically USB 3.0 devices to try out, but that's a good suggestion. I'm also thinking that if the problem is with the USB port, maybe I'll get a USB 3.1 PCIe card and test that out (so as to bypass the alleged "bad" USB 3.0 ports). I'll post again when I've had a chance to try that out.

  • Hey Blosser.

    I'm with the Microsoft development team.
    Thanks for reporting the issue and filing the feedback. I am actively investigating the logs and we'll get back to you with a solution as soon as possible.


  • @Blosser

    Thanks again for reporting the issue. We found the Feedback Hub feedback filed and we were able to identify your USB host controller as a unit made by Etron. After finding one of these parts we were able to reproduce the failure and identified a compliance issue with that controller.

    We are initiating a conversation with Etron concerning this chipset and hopefully we'll be able to drive that to resolution.

    In the meantime, I suggest trying a different USB 3.0 host controller.
    You'll want to make sure to only install the Microsoft XHCI drivers:


  • I seem to be having the exact same problem.

    My previous post: https://forums.hololens.com/discussion/8544/acer-mixed-reality-headset-initial-setup-difficulties#latest

    I also notice that I have Etron hardware (see image below). Hopefully this can be resolved in a future update.

  • @BenP - What about the Surface Book issue with the USB 3.0 Port? Is there an ongoing investigation on this also?

  • paaronpaaron admin
    edited October 2017

    Blosser, can you file a Feedback item for this issue? We'd like to get some additional data on this issue. And can you provide the aka link that is generated in the App so that we can find it quickly. Thanks.

  • @paaron Sure thing! Here is the link to the feedback issue I had submitted: https://aka.ms/Ij0wsq

  • @BenP Thanks for looking into this! I did get a separate USB 3.1 PCIe card (Rosewill RC-509 ASM1142 ASMedia Chipset) to use. Once it was installed and had the Microsoft XHCI drivers the Acer headset started working. So it seems you were correct that the Etron USB was the issue.

  • @Blosser I'm glad to hear that resolved your issue!

    @CounterSeal I suggest acquiring an additional pcie USB 3 card. I don't currently have an outlook for a fix with Etron.

    @Fat_Bastard I just read through your linked thread. I will see if I can find details on the state of that issue.
  • @BenP JHalmans_Microsoft has posted a work around which worked really well.
    Apperently this is the same issue with the Kinect.

  • So I got the Samsung odyssey today. I went through the setup and everything went well. However, when I try to use the headset, the display on the headset goes blank after like a min or so, while everything still shows on my desktop screen. I still here sound from the headsets. I have gone through the troubleshooting page and did everything it told me to do (restart the app and what now), but nothing helps. I'm currently running i5 gtx970. I've made sure everything is up to date and all. Is anyone having a similar problem or knows how to resolve this? Thank you.

    Edit: i've also made sure my HDMI is properly connected and usb is connected to a 3.0 and have even changed slots
  • Hey SketchyGiraffe.
    I'd suggest starting a new thread to make sure this gets the correct attentions. Also, please use Feedback Hub to file new feedback under Mixed Reality. This will get us logs and hopefully we can get you a resolution.

    BenP - From Microsoft.

  • Greetings everyone. I see some of the links at the top of the post are not working. What is the process of going through getting rid of the Etron drivers and installing Microsoft 3.0 drivers? I have the retail Acer headset, and I'm facing constant crashes, which turn off the headset completely. Tons of -7 -4 errors, and asking me to "connect my headset." I can't get a single SteamVR game, or non-MS store games to work. Only the cliffhouse and ghostbusters (haha).

Sign In or Register to comment.