Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Acer Headset doesnt work / Mixed Reality Portal isnt either

I cannot for the life of me get this thing working. It shows up in Hardware, I got all the green checks. Then it just said "Connect your Headset", and I cannot get it to work.

Updated Nvidia drivers, now the Mixed Reality Portal just doesnt work at all, comes up then disappears.

When I first plugged in the headset as reccommended before switching to Creator/Insider, it worked (The headset). Now I can get a brief flicker if I plug / unplug USB.

Stuck and frustrated.. :(


  • ahalimahalim ✭✭
    Which version of Windows Preview Build are you using ?
  • Are you sure your USB3 ports are not running at USB2 speeds? Make sure u install the last drivers for the chipsets.

  • I occasionally run into the same thing. Sometimes the headset works, sometimes it does not. Despite showing up in the control panel sometimes the Mixed Reality Portal shows the headset has a status of "disconnected" and shows the message "Connect your headset." When this happens if I reboot the problem may or may not be corrected. It may take several reboots until the Mixed Reality Portal recognizes the headset.

    For me this occurs on Windows build 116241.rs_prerelease.170708-1800

  • @j2inet - I had the same behavior. Crashes randomly, or when loss of tracking. Since upgrading to 16257 those issues have been resolved. Please consider moving up to that build if you have not already.

  • Since updating to a newer build it's been a lot more stable. Some other problems I had (not mentioned above) have also gone away.

  • I have the same exact issue as OP. Any solutions??? I get green check marks, the headset is clearly connected, I followed all the steps, but just keeps saying "Connect your headset."

  • Hi @armanNV,

    I am from the Microsoft team. Could you try plugging the headset into other USB 3.0 ports on your system? This is just to rule out a specific issue with one port.

    If that doesn't help, please submit a feedback item for this issue through the Feedback Hub that is installed on the system. Once you've created a feedback item, please post a link to it, and we'll inspect the diagnostic data.

  • SOLVED - I have this issue, but only when the VR headset is trying to run a earphone/mic headset attached to it. It's a power issue. The headset starts drawing too much power and disconnects because of the limitations of the USB power output.

    So if you're NOT USING a mic/earphones, your mobo is having issues putting out the power required to run the VR headset.

    Figured this out after trying on my OMEN with a 1070 and my desktop with a 980ti with the exact same results. The only common factor was the earphones/mic. Try routing around the audio output, else if you're having issues with the headset solo, try getting a USB 3.0 HUB with an external power input to boost power output performance. Remove all USB extension cords from your setup.

    This is my experience with the Acer product. May return, not sure.

Sign In or Register to comment.