Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Mixed reality portal does not recognize USB 3.0

Mixed reality portal does not recognize USB 3.0 on my PC, I have 4 ports that work perfectly


  • @Spikey if you need assistance from the members of this Forum, you need to post Computer Systems Specs, relevant information that give some insight into what you are working with to enable us to troubleshoot and make an assessment. Post your Device Manager Screen. Do your Windows Logs give you any error messages? I am a Technical Trainer, quite willing to spend the time as it builds further experience with this new technology. I have been in the PC environment since 1983.

    Legacy MCSE SCO ACE CompTIA A+ Network+ Professional.
    Former Microsoft Certified Trainer (MCT), Authorized UNIX & LINUX Trainer, Accountant.

  • Hi,

    I'm experiencing the same issue. When I connect the headset it runs through the specification check - no issues.

    When you then click next i get the below error - please make sure your headset is connected to a USB 3 superspeed port.

    I've checked the ports with a usb 3 card reader and all is find - speeds etc.

    I've also used USB tree viewer to look at whats going on - to try and explain when I connect any other usb 3 device it connects the SS port, when ever I connect the headset to a USB H speed port.........

    I updated the USB 3 driver (long shot as I read you needed the generic MS one) - no difference

    I then installed USB 3 PCI card with a 900ma power line, same issue when I plug the headset it thinks its a USB 2 device.

    Finally I try a powered USB 3 hub to see if I could fool it to think there was a USB 3 device connected - this time it worked????strange?????

    However I know get the head set loosing connection 4 or 5 times per hour.

    Any help, advice is greatly appreciated as this is Christmas present for my son and I only have a few days to resolve it. :(

    Thanks in advance,


  • OK - another update, took the headset back to PC world and they exchanged it.

    I uninstalled mixed reality and plugged in the new headset direct to my PC. Recognized it immediately as USB 3.0 - YES!!!!!

    Only issue now is I still have loosing connection issue...... Again one of the host controller had an error code 43..... again help and advice is really appreciated.

    only 3 days to Christmas :(

  • Legacy MCSE SCO ACE CompTIA A+ Network+ Professional.
    Former Microsoft Certified Trainer (MCT), Authorized UNIX & LINUX Trainer, Accountant.

  • Hey Mance, I am getting the same problem with my HP MR device, worked up until a couple of months ago, now getting all the ticks in the portal but then get error 1, my PC is an X399 Motherboard, Windows 10 seems to have issues with it, does anyone know a fix?

  • Has anyone found a fix yet, this is labelled answered but I can't see the solution?

    I have the same issues with the PC using USB 3 fine until you plug the headset in and then it's 2.0

Sign In or Register to comment.