Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Why can't I deploy my solution to one of the two HoloLens headsets I have through Wi-Fi?

edited April 2018 in Questions And Answers

I'm a university intern, and have two HoloLens headsets within a company that I should not explain what we are.. On an unsecured Wi-Fi network, one of them can have the apps be deployed by Remote Machine on that network or by Device mode through Visual Studio 2017. The other one, though, can only have a solution be deployed to it by Device mode.

I don't understand why I can only deploy my compiled solution to one of them rather than the both of them. On the Wi-Fi Properties group in the Advanced Settings pane, both of them say the Wi-Fi type is 802.11ac.

Are there any files or settings on the Windows Device Portal that would restrict one HoloLens from downloading a solution I'm trying to deploy? This is something me and my partners have been trying to figure out for the past three months.

Our first impression is that our Wi-Fi network may be too slow, but if that's the case, then it would not be possible to deploy the solution to one of them. It doesn't make sense with the evidence we have. Another impression is that there's something wrong with the Wi-Fi dongle that's in the troubled HoloLens, but if that's the case, it would not be connected to the network at all. And now, my impression is that there's something in the connection settings that's restricting it from loading the app being deployed through Wi-Fi.

I don't know if resetting the HoloLens to factory settings is going to solve the problem.


  • dbarrettdbarrett ✭✭✭

    What error is it giving you?

    AR Developer

  • On the Visual Studio 2017 Build Window:

    Error DEP6957: Failed to connect to device '<CONFIDENTIAL_IP>' using Universal Authentication. Please verify the correct remote authentication mode is specified in the project debug settings. COMException - The network event being waited on triggered an error. [0x8007274C] SharedHolograms

    The IP address I wrote in the Start Options pane for the solution's Debug Properties does match the IP address that's shown in the Wi-Fi Properties pane on the HoloLens, though. Something I didn't point out was that on the other HoloLens, it's able to accept incoming apps from Visual Studio in Universal Authentication mode.

  • Here's additional output to help us out. I tried out the two other authentication modes I have as well: Windows, and None.

    Error: Unable to connect to the Microsoft Visual Studio Remote Debugger named '<CONFIDENTIAL_IP>'. The Visual Studio 2017 Remote Debugger (MSVSMON.EXE) does not appear to be running on the remote computer. This may be because a firewall is preventing communication to the remote computer. Please see Help for assistance on configuring remote debugging.

    All three modes display a popup saying the solution must be deployed first before it can run.

  • While I wait for access to the troubled HoloLens to test the fix out, I got a question to ask.

    From a live session video I watched on YouTube regarding Spectator View, is it true that to run Spectator View on multiple HoloLens headsets with one Spectator View rig, the Unity app that's been built must be deployed by Wi-Fi only?

    If it is, then I hope the solution in the StackOverflow link above works; otherwise, I'll need to figure out what networking components to add to my scene and then deploy the app to both headsets and attempt to connect each other.

  • dbarrettdbarrett ✭✭✭

    It doesn't matter how they are deployed. However, when running the app they need to be on the same network.

    AR Developer

  • I did try that earlier, and the solution did deploy and run, but I still got the "Available Sessions" interface, which really shouldn't be there. In addition, the interface won't let me use gestures to create a new session where another HoloLens would join because the cursor does not respond to air taps.

    That means that the hologram's position in the real world is not synced between both HoloLens headsets as what Spectator View is supposed to do.

  • Hang on, there's something that doesn't make any sense here, because I still think the HoloLens itself has to communicate with my PC via Wi-Fi to share the hologram's position so that the Sharing Service hub can propagate it to the other HoloLens I got.

    If you're saying it doesn't matter how my solution is deployed, then why is one HoloLens headset not communicating with my PC when it, the PC itself, and the other HoloLens headset are all connected to the same network?

  • edited April 2018

    By the way, I tried a different configuration, but I am not getting a prompt on Visual Studio 2017 to enter a PIN in order to pair the troubled HoloLens. Why is my laptop not detecting it at all even if both devices are on the same network?

    It always works with the other HoloLens we got, so it can't necessarily be the firewall. The HoloLens I'm stuck with has Developer Mode turned on, and even before I tried it out, I removed all of the PINs used to pair it with other devices.

  • dbarrettdbarrett ✭✭✭
    edited April 2018


    AR Developer

  • The response does not have any context. :(

Sign In or Register to comment.