Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Can't deploy app to HoloLens emulator, device, or over wifi (error DEP6100).

I'm following the sample projects on the HoloLens Academy and I get the following error every time I try to deploy. I installed all of the required tools (in the proper order) and have the correct system requirements and this error fails the app deployment to all of the target devices- remote machine, emulator, device. Should I see a VM running in Hyper-V before deploying? I haven't been able to track down this error with resolution yet.

Severity Code Description Project File Line Suppression State
Error DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device 'A2152254-0A5F-7C78-A684-1D8072A02DF5'.':
TypeLoadException - Could not load type 'Microsoft.VisualStudio.ImmersiveProjectServices.Shared.DeployLoggingStrings' from assembly 'Microsoft.VisualStudio.TailoredProjectServices, Version=14.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. Holograms

Best Answer

Answers

  • I get the same error when trying to deploy a Holographic DirectX 11 app.

  • Glad you fixed it and thank you for posting the solution for others.

  • Severity Code Description Project File Line Source Suppression State
    Error DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device 'A2152254-0A5F-7C78-A684-1D8072A02DF5'.':
    NullReferenceException - Object reference not set to an instance of an object. HolographicApp3 IntelliSense
    I have done everything which is mentioned above but still I am not able to deploy HoloLens emulator. Plus when I tried to run this app on local machine it gave me an error like app registration failed. So please help me.

Sign In or Register to comment.