Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

how to use the Holographic DirectX11 development template file

I am new to Holographic DirectX11 development. I have windows 10, VS 2015 enterprise version, and emulator installed. I followed the steps at https://developer.microsoft.com/en-us/windows/holographic/creating_a_holographic_directx_project
I can see the template files at
C:\Users\xxxxx\Documents\Visual Studio 2015\Templates\ProjectTemplates\Visual C++ Project\HDirectXAppCPP.zip
However, when I try to create a new project in VC++, there is no option for "Windows > Universal > Holographic node and select Holographic DirectX 11 App (Universal Windows)."
My screen looks like this.

would you please tell me how to use the this template? Thank you.

vc.jpg 72.6K


  • Just trying to guess the answer here.

    Did you install the latest VS2015 Update 3? I also remember that during the installation some additional features had to be enabled in the installer (it seems plain installation with all defaults might not be enough):

    Quote from the tools page: If you choose a custom install, ensure that Tools (1.4) and Windows 10 SDK (10.0.10586) is enabled under Universal Windows App Development Tools node.

    So re-running the installer should allow you to add the missing features.

    More info is at:

  • thank you for the reply. I did full installation of VS 2015 update 3. Just to be sure, I did fresh installation of Windows 10 and re-installed VS 2015 this morning. Still thesame, any clue? Thank you....

    any clue?

  • I just figure it out. I have to run VS 2015, instead of Blend for VS 2015. The options show up. Thank you.

Sign In or Register to comment.