Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Issue with HoloLens Emulator

KawaiKawai
edited September 2016 in Questions And Answers

Hi,
I have this issue with the HoloLens Emulator. I use a MacBook Pro late 2015 model. Things were working fine until the last Windows Update on Friday. After that, the emulator couldn't start due to Hyper V problems. I fixed the Hyper V by disabling and then re-enabling and even uninstalled and reinstalled the emulator. Now, when I try to run it. It gives me the following error message:

The emulator is unable to connect to the device operating system: Object reference not set to an instance of an object.

Can anyone help?

Tagged:

Answers

  • Hi, I think the communication between Visual Studio and the Hyper-V VM is blocked by the firewall. Can you deactivate the firewall to test that?

    Pad

  • Nope, that didn't work :(

  • I got the same problem today. The emulator is only a virtual machine in the hyper-v manager. The installation process also create two virtual internal networkadapter. In my case they were disabled.
    So look into the network and sharing center and then on the left "change adapter settings". Next to your physical adapters are also two vEthernet Adapters (Internal Ehternet Port Microsoft Emulator NAT Switch, Internal Ethernet Port Windows Phone Emulator Internal Switch). They have to be enabled.

    I hope thats it.

  • I tried that and it didn't work as well. So, I uninstalled Visual Studio and reinstalled it, this time the emulators are all gone :'( :s

  • Hi Kawai, I got this problem too. Did you solve it after reinstall all the stuff?

  • Hi Yifan, not really. In the end I had to reinstall my entire OS. Please do reply if you find a solution.

Sign In or Register to comment.