Deactivate sleep function on Windows Mixed Reality headset

Hello,

We develop VR content, and we have choose the Samsung Odyssey as WMR headset.
We are facing a problem, the headset goes asleep to fast.
Is there a way to deactivate or increase the time of the sleep function.

Thank in advance for your answer or your tips.

Comments

  • Hi AllVirtual, there is not a setting for this currently. However you can vote up this request in Feedback Hub. This would be excellent feedback to send to the Mixed Reality team.

  • Hi AllVirtual,

    JayZuo is correct. There is no way to change the timeout value of the HMD to a value beyond 30 minutes. In previous builds you were able to set the time out to zero and it would keep the HMD enabled indefinitely. Unfortunately in the latest builds you can no longer set the timeout to zero. That said is there a particular scenario that requires you to keep HMD awake for a longer period of time? When the HMD goes to sleep you should be able to wake it up and just pick up where you left off.

    Thanks,

    James

  • @JDailey said:
    When the HMD goes to sleep you should be able to wake it up and just pick up where you left off.

    Unfortunately not - after the device (in our case, a HoloLens) comes back from sleep all the spatial mapping is messed up and we need to restart the app. I imagine @AllVirtual might have a similar issue.

    Plus, in a demo scenario like at a kiosk you want to be able to pick up and be running instantly when someone wants to see the demo - waiting half a minute for the device to "wake up" wastes people's time.

  • I see at least 2 gaming scenarios and i am not alone.

    Flight simulator : impossible to handle a long flight, you set autopilot on you remove your headset and when you're back headset is in sleep mode and app is closed...

    Racing simulator : you want to drive in an endurance race with ai as teammate. You swap driver giving control to ai, you remove headset and when you're back for your stint... headset is in sleep mode and app is closed...

  • This is very important for development!

    We have several headsets and I would be using WMR all the time because of how convenient is to put on, to test, to lift the visor to type, etc, etc. But the auto sleep function RUINS IT. SteamVR apps are closed, takes a while to start (and several tries, sometimes), and worst of all, sound is changed in some VoIP apps EVEN WHEN CONFIGURED NOT TO.

    Just for this reason I use the Vive.

    For gaming and kiosks it is a nice feature to have as well.

    I'm afraid this issue doesn't really affect many people, so judging just by the amount of votes in the Feedback Hub it won't really receive attention...

  • edited May 16

    Does that mean the Vive can stay active indefinitely even after removing ?

  • YoyoYoyo

    The Mixed Reality Portal has an idle timer that is used to prevent Screen burn-in on Mixed Reality Headsets. By default, this timer is set to 15 minutes (900,000 milliseconds). Physically moving the Mixed Reality Headset should result in this timer being reset. If you keep the Headset still for the duration of this timer, then Mixed Reality Portal will go idle, causing the Headset to go into a lower power mode where the display is turned off.

    WARNING: Changing this idle timer to longer than the default can lead to Screen burn-in on Mixed Reality Headsets!

    The registry key that overrides the timer value is at:
    Key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Holographic
    Value IdleTimerDuration
    Type REG_DWORD
    Data The Mixed Reality Portal idle timer specified in milliseconds

    NOTE: Please take care when modifying the registry as unintended changes can cause system instability!

    Increasing this timer value can be helpful in kiosk or demo scenarios. If you are building an app for such a scenario, please consider implementing Screen burn-in prevention features into the app. The maximum supported timeout value is 0xFFFFFFFF. To mitigate Screen burn-in on Mixed Reality Headsets, ensure that the screen doesn’t show a static image for extended periods.

  • Thanks for the info but given the risk you point out it means we can't suspend sleep mode to play endurance races with ai swap or long flights with autopilot.
    And it's a really bad idea to put a tape on the sensor (it never worked for me).
    Is it possible to hope that the sleep mode will be changed so it doesn't kill the app ?

  • I tested Yoyo's solution and it works fine.
    The IdleTimerDuration didn't exist in the registry path so i created it with 3 600 000
    as decimal value. The idle occurs one hour after i started a race and remove the headset.
    So it's now possible to drive in endurance race with ai as teammate or to fly with autopilot.
    In flight scenarios it's required to choose a view which changes periodically to avoid the screen burn. In endurance race the ai is driving so there is no static image.

    The only risk remaining is a an app crash which would get the view back to a static image.

  • A good solution would be to power off the screens of the headset when it is not in your head, so the app will continue rendering but the screens will not be burned, specially if you are using an amoled screen headset, such as Samsung Odyssey.

    To improve energy saving when the headset is not in you head, the framerate could be set at 30fps or less.

    Other sugestion: Always ask to the user if the headset should go to sleep (with a timeout to answer yes automatically) instead of doing it without any warning.

    The user will lose the unsaved data in the game if it is being suddenly closed.

    And finally an option in the UI to disable this behaviour forever (very useful if you are a developer).

Sign In or Register to comment.