Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Speech/voice recognition delayed since rs4 update in july 2018 on HoloLens

Hello together,

Our Problem:

After the RS4 Update the speech recognition takes longer than before.
Speech recognition is delayed 1 - 3 seconds after saying the keywords in contrast to instand reaction before the update.

We are using:

KeyWordManager with "Speech Input Source" and "Speech Input Handler" from HoloToolkit and an own script referencing the KeywordRecognizer within Unity.

What we checked:

We've already checked this problem with Unity 2017.3.1p3 and 2018.2.0f2, HoloToolkit 2017.1.2 and 2017.4 in various configurations.

Please help us, has anyone else the same problem or an solution?


  • We have the same issue. Randomly the speech recognition will be immediate or severely delayed. Some times up to 10seconds!
    Previously, we never had any problems with that.
    It seems to be only for unity apps as there's no problem with the speech to text in the menu :/

  • I have similar issue. Voice commands will work for a while then randomly stop working and cortana even becomes unresponsive. I tried upgrading to RS5 but that didn't fix the issue. No exceptions or errors thrown either.

  • We have seen this issue also. Performing a Device Reset has fixed this on 2 of our devices. While a little painful to go through the process it seems to help.

  • Really? I reset the device(s) several times (for modifying provisionning profile and so on) and haven't seen any improvement.
    Did you use the windows device recovery tool or just the reset device button from the settings?

  • JonRJonR
    edited August 2018

    An update on the device reset situation. We initially found that a full device reset from settings provided an improvement on several devices tested. Unfortunately after use with a heavy cpu load the problem returns.

  • Axelius89Axelius89
    edited September 2018

    We are experiencing the same issue. Initially all the keywords are being picked up flawlessly, but the app stops recognizing after a while. The field IsRunning of the KeywordRecognizer in SpeechInputSource is still true and none of the OnDestroy or OnDisable etc functions of SpeechInputSource are called.

    I found out that time seems to be not the decisive factor, but sound or speech which is being picked up that does not trigger a keyword: I spend several minutes in a quiet environment saying the same two keywords back and forth and each time they triggered flawlessly. But when I started speaking a few other sentences and then trying to trigger a keyword it was delayed by several seconds. When I speak nonsense for too long the keywords after that seem not to be triggered at all any more. (Or they might be triggered only after a few minutes, which would be just as useless )

    This behavior is especially problematic when giving a demo of the software, because you might be explaining the application or people might be talking in the background, which results in the keywords not triggering any more.

    It seems to me that some buffer is filling up when the HoloLens picks up sounds or speech that do not trigger keywords, which takes some time to process which explains the delay.

    Anybody got an idea?

    I'm using Unity 2018.2.4f1, the HoloLens is running RS4, MRTKVersion is 2017.4.1.0, VisualStudio Enterprise is 2017 15.8.1 and my application is receiving many UDP packages from an outside-in tracking system. I also tried it with another HoloLens, which is also running RS4.

  • Any improvement with the latest RS5 build? We tried a quick test and it seemed to work fine but have not run an extensive test.

  • This is affecting us too - I've put in an enterprise support ticket with MS so we'll see what they say.

    Our experience is that voice commands start fine, then get progressively more delayed as we use the app and time goes by. Sometimes, we'll get a 'burst' of responses - like we say a command, nothing happens, we say it again 2-3x every 2-3 seconds, then some time later all commands will invoke at the same time. Quite odd...

    Eventually, voice commands stop working altogether.

    We also feel like this started around RS4, before then I never recall having this issue.

  • We experience the same behavior with our Unity app. The speech recognition works fine at the beginning but then progressively get slower and slower

  • Updated this Morning to RS5 and it seems that the recognition is working fine now..

  • Anyone have a solution for this? Started seeing this in the RS5 inside preview builds, speech would stop working within a couple of minutes. I removed the insider builds and reset the device to RS5 (17763.134.x86fre.rs5_release_svc_prod1.181101-1643) and it is better but after a while speech stops working again.

  • Found this support page to revert HoloLens windows version: https://support.microsoft.com/en-us/help/12643/hololens-update-hololens.

    It has a link to the RS1 package, does anyone know if other builds are available such as RS2 or RS3? The WDRT tool will currently reset to RS5 unless another package is provided.

  • I have the same problems with the delayed speech recognition.
    I found out that If I turn off the Wifi in the settings of the HoloLens the speech recognition is working perfect again.

  • @DanielFuchs91 said:
    I have the same problems with the delayed speech recognition.
    I found out that If I turn off the Wifi in the settings of the HoloLens the speech recognition is working perfect again.

    It works for me with deactivating Cortana (Settings --> Privacy --> Speech & typing --> Turn off speech services and typing suggestions).
    With this option I can turn on the Wifi again.

  • I have a "kind-of" similar problem with speech recognition:
    Case 1: Hololens connected to internet through wifi: speech recognition works
    Case 2: Wifi turned off: speech recognition works
    Case 3: Hololens connected to a wifi hotspot with NO internet access: speech recognition has at best 30s lag, at worst no recognition at all.

    I have tried the solution from @DanielFuchs91 (deactivating Cortana: Settings --> Privacy --> Speech & typing --> Turn off speech services and typing suggestions), and it worked for Case 3.

    OS build number: 10.0.17134.111
    Unity: 2017.4.5f1
    MRTK: 2017.4.0.0

  • I'm having the same problems, the voice recognition works well at first but the more people are talking in a room the worse it gets. Often I have multiple hololens with the same build and voice recognition will work on one of the two devices. The failure rate is very high. Powering the device on and off seems to help. I think there's something failing behind the scenes and it's not showing any error messages. I also have an issue where sometimes all voice input is blocked on the entire hololens and when a build is pushed I get the following error when the app starts.

    Exception thrown: 'UnityEngine.UnityException' in UnityEngineProxy.dll
    'sbirs-ar.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Data\Users\DefaultAccount\AppData\Local\DevelopmentFiles\sbirs-arVS.Release_x86.ww31785\System.Diagnostics.StackTrace.dll'. Symbols loaded.
    UnityException: Speech recognition is not supported on this machine.
    at UnityEngineProxy.InternalCalls.PhraseRecognizer_CUSTOM_Start_Internal(IntPtr recognizer)
    at UnityEngine.Windows.Speech.PhraseRecognizer.Start()
    at Src_GrammarRecognizer.Start()
    at Src_GrammarRecognizer.$Invoke2(Int64 instance, Int64* args)
    at UnityEngine.Internal.$MethodUtility.InvokeMethod(Int64 instance, Int64* args, IntPtr method)
    (Filename: Line: 0)

Sign In or Register to comment.