Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Holograms 240 - Devices can't connect to server

I'm having trouble getting past Chapter 3 of Holograms 240.
To reduce user-error, I've resorted to running the Catchup-Chapters > 7-Finale files from the download package.
That project builds fine and runs properly within the Unity editor. It even connects to the local HoloToolkit Sharing Service as seen through the log.
However, after building and installing on the HoloLens devices, the Sharing Holograms app does not seem to connect to the Sharing Service server.
I've opened up the Windows Firewall to both local and public networks.

When I run Sharing Holograms on the HoloLenses, all I get a 4 robot heads that can be air-tapped, but then nothing. No connection to the server is logged.

The Unity computer and the 2 HoloLenses are all on the same WiFi network.

Any ideas what I could be doing wrong?

Best Answer

Answers

  • AlexDAlexD ✭✭✭

    Make sure you enabled the proper capabilities in Player settings (Build Settings - Player Settings - Publishing Settings - Capabilities): InternetClient, InternetClientServer, PrivateNetworkClientServer.
    I think only PrivateNetworkClientServer is required, but I put the others as well for good measure.

  • In addition to what @AlexD mentioned please ensure your device and sharing service is running on the same network.

  • Hi ,
    i am facing connection issue,i follow same process as per your suggestion but hololens not connecting with server.if you give some detail regarding this connection then it great help.

  • hi all,

    I am facing a problem when trying to connect two hololens. I tried all IP address which displayed in launch services but hololens not getting connected. I enabled capability InternetClient, InternetClientServer, PrivateNetworkClientServer, but nothing working for me.

    If any one can help that will great for me.

Sign In or Register to comment.