Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Only audio & no holograms (black screen) when unity project deployed to Hololens

Hi everyone,

I'm working on a Augmented Reality project in Unity 2018.2.9f1. So, I use unity to develop the project, then build a solution for Visual Studio 2017 and then, via Visual Studio, deploy the project to Microsoft Hololens.

I did this in the last few months without any problem, and everything was working fine: the project worked in the unity editor when I hit PLAY, and worked exactly in the same way on the Hololens. Then, all of a sudden, something went wrong and now, when I deploy the project to the Hololens, I have only a black screen. No holograms at all, and not even the "made with unity" logo when the app starts. However, I can still hear all the sounds that I created, as if the app was working as normal.
During the deploy process I get no error and no warnings.
In unity editor everything works fine, even when I hit play.

Also, I reinstalled Visual Studio, no change; in Unity, I cleaned the cash, canceled the Library folder and had unity to recreate it, no change; I exported my original project as an asset, created a new project, imported in it my exported asset, no change.
Hololens software is updated to the latest version. Windows 10 is updated to the latest version available.

If I run on the Hololens old versions of my project I can see the holograms.

Worst of all, if I create a new project in Unity and add to a new scene just a cube, build a solution and deploy it to the Hololens I can see the cube and also the "made with unity" logo.

I guess that the problem has to do with something in my project. An asset, maybe, a script, something wrong with some setting? However, the project was working fine until a few days ago and I did not introduce major changes to it.

I'm not a developer; I'm getting familiar with unity, but I guess not familiar enough to find a solution to this situation.
So my question is: where do I start from in order to find out what is wrong with my project?

Any help would really be appreciated.

Thanks

Sign In or Register to comment.