Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Is this the proper workflow for Holograms_240 (SharingService)?

Greetings,

I am having difficulty connecting two machines using the SharingService as outlined in HoloGrams_240.

I've created the project as specified by the page; I've then built it twice. Once on the Server machine with "localhost" (and alternatively, the host machine's own IP address), and once on the Client machine using the IP address of the Server machine for the "Server Address" field on the Sharing prefab. On this build, I've also tried toggling the "Client Role" to Secondary (as well as Primary and Unknown).

I've also tried using the Sharing.unity example from the HoloToolkit. Regardless of Project, when running the Build on the Secondary machine, I do not see a trace of a successful join in the SharingService of the Primary machine.

I've tried running the Project Build on the Server machine and Client machine with various combinations of two HoloLens devices or two Emulators. Nothing seems to do the trick. I've also tried simply running Preview mode in Unity.

Pinging the Host machine from the Client machine is successful; the ports are matching on both ends.

My understanding of machine networking is limited. Can anyone confirm my approach is correct, or better yet suggest some first steps to debugging this issue?

Thank you for your support,
Sally

Tagged:

Best Answers

Answers

  • Hi Sally.

    Only one PC should be running the sharing service. The IP Address of the machine running the sharing service should be put in the Server Address field of the prefab on all PCs building the experience.

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • Hey Patrick,

    Thank you for the comment. This is the case, although the single machine running the Sharing Service is also running a game build, acting as both the Server and a Client.

    Could this be the issue? Is it expected that a third machine should be running the Service independent of the two Player machines?

    Thank you for your support.
    Best,
    Sally

  • What do you mean by running a game build?

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • By "running a game build", I mean that I have done the following:

    • built the game on the respective machine via the Unity Editor
    • opened the Solution from the newly created Build in Visual Studio
    • deployed and ran the Solution through the HoloLens

    Thank you!

  • Hey Patrick,

    I have followed your instructions to use a single PC running the SharingService and deploy from there onto two HoloLenses. This was a successful deployment, I see both devices have joined the shared session.

    I am now getting Room deserialization errors which crash the deployed executable running on the second HoloLense to join the session. I will try the suggestions listed on this related thread to address the failure.

    In the meantime, I consider this thread resolved.

    Thank you so much for your prompt and helpful advice.

    Best regards,
    Sally

  • great! Do start another thread if you are still having issues deserializing. I don't know of any crashes.

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • doris4730doris4730
    edited April 2017

    I have the same problem, unsuccessfully trying to connect hololens to pc running sharing service.
    I follow all steps in tutorial, then try to use completed project but it not working.
    Sharing service gives me this three addresses:
    172.16.80.1
    172.18.18.26
    169.254.80.80
    I copy and paste it one by one at Server Address field in sharing prefab, it work in editor, but not work in hololens.
    I don't understand why it doesn't work. Any ideas or suggestions?

Sign In or Register to comment.