Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Unable to activate Windows Store app

Was going through the holographic academy lessons yesterday. Made it through 100 just fine. Moved on to 101 and came across this error "Unable to activate Windows app 'Origami_sx6pycx103f58!App'. The activation request failed with error 'Windows was unable to communicate with the target application. This usually indicates that the target application's process aborted."

I tried several times, and continued to get the same error. I also went back to 100 and tried to launch again and now 100 gives me the same error.

I tried it in both USB connection and wifi.

Not sure what to do from this point. Any suggestions?



  • @KrisFobes have you tried connecting to the HoloLens with Device Portal and manually shutting down any version of the Origami app.
    This image shows the X that closes the app (in this case it is the Photo app)

    You might also want to try the Restarting the device from the Device Portal:

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • Hey @HoloSheep I tried doing as you said and connecting to the device portal to remove and stop previous versions of the app... still have no luck. I also tried restarting several times from the device portal and get the same result. After that I tried unpairing the device and re pairing and I still get the same response.

    Any other ideas?? Is there any issue that might be on the VS side?

  • I also attended the last winHUGR Redmond group. :) If you want to meet somewhere and see it in person, Id be more than happy to show you.

  • @KrisFobes before we resort to a "house call" :smile:

    Searching the forums on the phrase "unable to activate
    turns up a number of different threads with a variety of different resolution to this error. So I suspect that it may be the same or similar error for a few different scenarios.

    From the sounds of the message and my past experience with it, my first thought is that VS thinks the app is running but can't communicate with it. Hence the suggestion to kill previous instances or reboot.

    Have you tried checking off the "Uninstall and then re-install my package."
    checkbox in the Project Properties | Debug tab? Here is another thread that describes this setting helping for a different error message, but it might also clean up some of the state that may be causing this error for you.

    What versions of the tools do you have installed on your machine, and did you change anything in particular around the time that things started to act up?

    Have you ever installed Visual Studio Preview 15 on your machine?

    What Solution Configuration settings are you using (Release x86)? Have you tried changing from Release to Debug or vise versa and still get the same error?

    Are you "Staring Without Debugging" or "Start Debugging" and have you tried the opposite and still get the same error?

    I gather you have also tried rebooting both the dev machine and your device, but mention this one just incase you haven't.

    Let me know if any of these help and if not, maybe answers to a few of the questions will spark an idea from one of us. Also, sharing a screenshot of the error message might help.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • Hey @HoloSheep Thanks for all of the suggestions. I did google the crap outta this one and came up with a lot of the suggestions you've listed above.

    I did check off the uninstall/reinstall tab in the debug tab.

    Basically as far as the machine goes, I started with a fresh windows 10 install and installed unity and VS with updates specifically for hololens dev. I am running windows on a mac but that didn't seem to have any effect on the first project I built.

    I literally just sat down with my computer and my hololens with a fresh install of VS and unity and started going through the holographic academy. The first project went well without a problem and I was so excited that it went smoothly that I started the next "origami" project.

    This is when everything started going downhill...

    Blew through all of the instructions in unity and sent it to VS and ran everything exactly the same as I did previously but now I continue to get this error.

    Never installed VS preview 15.

    I have tried changing the release x86 options around.

    I did notice while in the portal that I have a bunch of processes running in the background. I guess slightly more than I was expecting as I always try to not have any windows or holograms left open. I try to have only a single app pinned and available at a time and I don't leave any holograms sitting around the office for people to look at.

    I have rebooted machine and hololens. I have also un-paired, reset IP, and re-paired with the device. I have tried running in both USB and wifi.

    I feel like the fix is going to be one of those simple "duh" moments.. but for whatever reason I can't see it.

    I will send a screen shot of the processes running. Maybe there is something I should end?

    Aside from ending processes that might be binding up the process, I think my next step is to wipe VS and start with a fresh install and install as many updates as I can find related to windows and hololens and pray that this doesn't happen again.


  • HoloSheepHoloSheep mod
    edited July 2016

    @KrisFobes have you install Visual Studio Update 3 and the recent "Patches" that are mentioned in this thread?

    Also have you tried killing the files and folders that Unity generates each time it builds like the following ones:

    and regenerating them?

    If all else fails (depending on how nearby you are) it might be interesting to swap out a different device and/or connect that device to a different dev environment to narrow down whether it is something funny on the device or in the dev environment setup.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • @HoloSheep I did try killing the files listed.

    I have a gut feeling it has to do with VS updates (or lack there of).

    I will re install VS and update it as much as I can and try again.

    Im in Kenmore BTW. Not sure if that is close to you or not.

  • Ok, I have a little update. I removed and reinstalled a few programs and ran through a very simple holograph creation on memory of what I remembered the steps to be.

    I did the build but in unity under build settings/player settings/rendering I forgot to click on the VR supported checkbox. So when I opened it from VS, it opened inside of a window that looked like the hololens emulator on my hololens.

    After it not opening in 3d I read through holographic academy 100 again and found my mistake. Changed it to support VR and tried to build again and got the same unable to activate windows store app error.

    Thinking about the convo above and the idea that it might have a contradicting app running. I unchecked the VR supported tab and built again. Again it built on the hololens and ran just fine, it just opened inside of an emulator and not in 3d.

    So is the windows holographic SDK that is enabled when I check the VR supported tab what is screwing things up?


  • Another update, I just did a build using the VR supported tab but changed from D3D to XAML and it seemed to work. I will try to do academy 101 and see if the success continues.

  • Using XAML I was able to build the Origami app just fine. Although the app itself seems slightly buggy, Im not sure if thats from using XAML or something else. I will continue using XAML for now unless there is a solution you can think of that allows me to switch back to D3D

  • Howdy,

    I don't know if you still have an issue, but I was running into the exact same error. I solved it (keeping the Unity deploy as D3D) by:

    • Using the HoloLens IP address rather than name for remote connect in Visual Studio

    • Following these instructions, "In Visual Studio, right click on Package.appxmanifest in the Solution Explorer and select View Code. Find the line specifying TargetDeviceFamily and change Name="Windows.Universal" to Name="Windows.Holographic". On the same line, change MaxVersionTested="10.0.10240.0" to MaxVersionTested="10.0.10586.0" Save the Package.appxmanifest."

    • In Visual Studio go to Project->Orgami Properties, click on Debug on the sidebar, and select Authentication Mode to be Universal, and check the box that states "Uninstall and then re-install my package. All information about the application state is deleted"

    After all of that I actually ran the app WITH debugging (selected the Do Not Ask Again Option) and it worked.

    Not sure which of the above exactly fixed it and it may not be advised to run with debugging, but I wanted to list everything I just did. I would guess it was the box that I checked that Uninstalls and Reinstalls in the Visual Studio project properties.

Sign In or Register to comment.