DEP6100 : The following unexpected error occurred during bootstrapping stage

On a Intel(R) Core(TM) i3-4130 CPU @ 3.40GHz, 3400 Mhz, 2 Core(s), 4 Logical Processor(s) I install everything (I re-installed everything three times) I get this error when I run a HoloLens project made with Unity in the emulator (the emulator starts up and runs fine, the project wont deploy to it):

DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device 'F957827B-6FC8-4538-A5BA-3B3807152A56'.':
MissingMethodException - Method not found: 'Boolean Microsoft.Tools.Connectivity.RemoteDevice.Ping()'.

I tried the following (posting it because it did not help me but may help others):

This:
http://daxdude.blogspot.com/2015/01/error-dep6100-bootstrapping-0x80131622.html

Or this:
http://stackoverflow.com/questions/16954220/windows-phone-8-emulator-cant-start/30507324#30507324

1.Go to "Turn Windows features on or off"
2.Remove Hyper-V
3.Restart
4.Reinstall Hyper-V
5.Restart
6.You're a go :)

After I did that I got this error:
http://stackoverflow.com/questions/29903619/windows-phone-emulator-not-starting-couldnt-setup-the-udp-port

The solutions above did not work for me. I found out that the issue was with the Hyper v adapters so I decided to deleted them which caused hyper -v to create them again.

These are the steps
1.Run cmd as admin and enter the following commands
set devmgr_show_nonpresent_devices=1
start devmgmt.msc
2.This will startup the device manager and show the list of hyper v network adapters
3.Right click and uninstall all hyper v network adapters
4.Open Hyper v manager and delete the virtual machines
5.From Virtual Switch Manager (right side of hyper-v manager), delete all internal switches
6.Restart the system and run visual studio and launch emulator
See this for more info http://www.gfi.com/blog/how-to-remove-hidden-network-adapters-from-virtual-machines/

Best Answers

Answers

  • wintermootwintermoot ✭✭
    edited April 2016

    thank you! this got me stuck too, but none of the above resolved my method not found: Microsoft.Tools.Connectivity.RemoteDevice.Ping

  • I did this...emulator worked perfectly...but lost my internet connection...fixed that and now having the same problem again :neutral: Looking for a way to make both work...any thoughts?

    --
    Blag.
    Developer Evangelist - Development Culture
    SAP Labs Silicon Valley.

  • @Blag said:
    I did this...emulator worked perfectly...but lost my internet connection...fixed that and now having the same problem again :neutral: Looking for a way to make both work...any thoughts?

    What step worked for you?

    Also, I realized that something unique about my computer is that I have a wired network card and also a Wi-Fi card. If I get a chance to get back to this (I may not because everything works fine on my Surface Pro so that is what I am using for now) I may try disabling my network card and just trying this with the Wi-Fi card.

  • This may be of help. Found this after re-reading
    In the Project panel HoloToolkit\Prefabs\SpatialMapping folder, find the RemoteMapping prefab.
    Drag & drop the RemoteMapping prefab into the Hierarchy panel.
    Select the Hierarchy panel, select the RemoteMapping object.
    In the Inspector panel, find the Remote Mesh Target (Script) component.
    Enter the desktop IPv4 address in the Server IP field. MY DESKTOP ETHERNET IS 192.168.2.92

    In the Inspector panel, find the Remote Mesh Source (Script) component

    Enter the desktop IPv4 address in the Server IP field.MY DESKTOP ETHERNET IS 192.168.2.92

    So I missed these IP address first time round caused blank screen

  • Thanks Kyle...but no luck for me :disappointed: The x86 path is there and the targeting platform is setup correctly...still getting the same error....

    The emulator is unable to determine the host IP address, which is used to communicate with the guest virtual machine

    --
    Blag.
    Developer Evangelist - Development Culture
    SAP Labs Silicon Valley.

  • tried all day to fix this with no luck. none of the above steps are working. I'm able to run the emulator and use the device portal just fine though.

  • @wintermoot said:
    tried all day to fix this with no luck. none of the above steps are working. I'm able to run the emulator and use the device portal just fine though.

    Yeah same here :(
    Do you have more than 1 network card?

  • @_Kyle said:
    So I had this problem too. You need to make sure that C:\Program Files (x86)\Windows Kits\10\bin\x86 exists, there is a dll there that contains this function. Secondly, you need to make sure your project is targeting platform version 10.0.10586.0 and not 10.0.10240.0 which it was defaulting to, at least for me(check in project pages in visual studio).

    Hope this helps,

    Kyle

    Mine is targeting 10.0.102040.0 but 10.0.10586.0 is not in the drop down. where else can I change this value in vs? (I right clicked the project and did properties)

  • wintermootwintermoot ✭✭
    edited April 2016

    @ADefWebserver said:

    @wintermoot said:
    tried all day to fix this with no luck. none of the above steps are working. I'm able to run the emulator and use the device portal just fine though.

    Yeah same here :(
    Do you have more than 1 network card?

    nope, one card but running in a vm. fixed my deploy issue, but now am getting the no internet problem

  • I had some issues related to deploy tonight regarding something wrong with my Visual Studio Update 2 installation. I have fixed it because it was a mistake on my part. I am now having an issue with the Internet also (so we can add this post to the "Me too"). I am on a Surface Book i7, 1TB, dGPU. I tried sharing the Internet, but with the others the adapters and virtual machine also get reset on every launch making the configuration useless. I also have Visual Studio 2015 U2 in a VMware Virtual Machine on my workstation. I am able to launch the HoloLens Emulator and run the apps, but also unable to make the Internet connection at this time. Both configurations consisting of 1 Network Card for External Access.

    Christopher Zenzel

    Shaping the Future by Being a Leader in Technology while Living with Autism (ASD). Looking for Opportunities in Magic.

    https://chriszenzel.com
    https://linkedin.com/in/chriszenzel

  • @wintermoot said:

    @_Kyle said:
    So I had this problem too. You need to make sure that C:\Program Files (x86)\Windows Kits\10\bin\x86 exists, there is a dll there that contains this function. Secondly, you need to make sure your project is targeting platform version 10.0.10586.0 and not 10.0.10240.0 which it was defaulting to, at least for me(check in project pages in visual studio).

    Hope this helps,

    Kyle

    Mine is targeting 10.0.102040.0 but 10.0.10586.0 is not in the drop down. where else can I change this value in vs? (I right clicked the project and did properties)

    I had to uninstall the windows sdk that came with visual studio and install the standalone sdk from MS's website.

  • I nuked from orbit and got internet back. reinstalling the sdk also helped.

  • Just saw this resolved on a system by uninstalling both the 10.0.26624 and 10.0.10586.212 sdks and reinstalling (no Visual Studio uninstall required, they were on Enterprise just for the record)

  • @AdamTuliperMS said:
    Just saw this resolved on a system by uninstalling both the 10.0.26624 and 10.0.10586.212 sdks and reinstalling (no Visual Studio uninstall required, they were on Enterprise just for the record)

    yes,u're right.when I check my sdk,the fifth and seventh features neee to be checked,but the fifth I didn't check.when all two are ready,deploy success!

  • I had this problem and I did the following things:

    1. Turn Hyper-V on and off
    2. Uninstalled all Hololens emulators and emulator images (Not Visual Studio though)
    3. Uninstalled both Unity HoloLens Preview versions
    4. Reinstalled everything

    This worked for me. It was a bit tedious, but I got it working (deployed to emulator). I did not uninstall the Windows SDK's just all HoloLens related items.

    Happy coding!

  • The solution for me was to run Visual Studio as an Administrator. (Right click on VS. Run as Administrator)
    Albeit, i did run into a few further issues deploying afterwards, I had things solved with a few minutes after.
    Additionally try testing with Debug instead of release.

  • I have tried almost everything discussed here. Still getting the same error. The emulator shows the same error "The emulator is unable to connect to the operating system: Object reference not set to an instance of an object. Some functionality might be disabled."

    and on the VS the error is:"
    Severity Code Description Project File Line Suppression State
    Error DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device '6C3DD314-EF85-06D2-68DF-7734EA48770B'.':
    ObjectDisposedException - Cannot access a disposed object.
    Object name: 'XdeServiceClient10_0'. Origami "

    I have been struggling with this for a while now. Can anyone help?

  • Just posting this here, as I ended up on this forum thread first when attempting to diagnose the same issue @isha95 had reported.

    After days of debugging and tweaking things, I discovered that these were the steps necessary to get things working on my end.
    1. Disable my VPN when using the emulator. This was probably the most important step to take. I use ExpressVPN and it creates a virtual network which all internet traffic is routed through. I'd assumed this would not apply to my local traffic, and my ignorance of this cost me dearly in terms of time.
    2. Configure windows firewall to allow XDE unrestricted communication. This page will give you everything you need to know in order to do so.
    3. Remove the HoloLens Emulator VM from Hyper-V and then reinstall it. This step was the most tricky to figure out. After completing the above steps I was finally able to connect to the emulator. However, upon doing so I was not able to use XDEs Human or Keyboard/Mouse inputs. After a bunch of trial and error I was finally able to overcome this by ditching the VM and deleting the virtual disks. You see, removing the HoloLens Emulator VM it does not remove the virtual disks. Once I'd removed the virtual disks and reinstalled the Emulator I was finally able to connect to the emulator with full functionality.

    I hope my findings will help someone else out there avoid the many wasted hours I experienced getting this to work correctly.

Sign In or Register to comment.