Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Animation - Unchecking Play Automatically

I don't want my animation to begin right away, so I unchecked play automatically, but I have a GazeGestureManager and PlayPauseCommands so that when the user gazes at the play button, the animation will begin. My PlayPauseCommands script was working when it was checked off (but the animation would begin right away); however, when it is unchecked it is no longer working. Here is my code snippet for what it should be doing when play is pressed:

foreach (var anim in allAnims)
foreach (AnimationState state in anim)
state.speed = 1;
isAnimated = true;

Is there another step I need to do since Play Automatically is unchecked?

Sign In or Register to comment.