Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Hololens app can't connect to server after changing router

I am writing an application for Hololens which communicates with a unity server on PC. The application worked and it transmitted data successfully back and forth. Of course, my router decided to die 3 weeks before the deadline, and now with the new router, the client on Hololens does not connect to the server anymore. The new router is a NetGear R6220. The computer is able to connect to the Hololens device portal, deploy and debug apps, but the client on Hololens cannot connect to the server, which leads me to believe it has to do with port 7777.

This is the log I'm getting:

Calling NetworkManager.singleton.StartClient()
'HoloNetworkingTest.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Data\Users\DefaultAccount\AppData\Local\DevelopmentFiles\HoloNetworkingTestVS.Debug_x86.*-*\System.Text.Encoding.Extensions.dll'. Module was built without symbols.
'HoloNetworkingTest.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Data\Users\DefaultAccount\AppData\Local\DevelopmentFiles\HoloNetworkingTestVS.Debug_x86.*-*\Microsoft.Win32.Primitives.dll'. Cannot find or open the PDB file.

Log: cannot connect after 10 attempt address {::ffff:}

I tried everything I could think of. I mapped the DHCP server to the same range of the old router so the PC has the same IP as before. I tried setting up port forwarding for 7777 to the PC's IP (although port forwarding shouldn't be needed). I opened port 7777 on the firewall for both TCP and UDP. I tried connecting to both 2.4G and 5G wifi. Nothing worked...

I tried to figure out what the error was by overriding OnFailedToConnect, but apparently the NetworkConnectionError enum is not available for Windows Store so it does not compile to Hololens.

Any help would be appreciated at this point. Thank you.



  • I switched to yet another router, and it works on this one. Still don't know why the Netgear router blocks specifically unity traffic on any port. If I host an HTTP server on the same port, it is accessible on it.

  • Have the same problem. Funnily enough Unity's NetworkDiscovery still works! Just that connectingvia high-level API (NetworkServer, NetworkClient) fails with 10 attempts message.

    Building the future of holographic navigation. We're hiring.

Sign In or Register to comment.