Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

App not deploying to Hololens. Dev mode enabled, but not in dev mode error.

When I deploy an app to the Hololens I'm getting an error that the device is not in developer mode, although the device is definitely in developer mode. I used the PIN to connect the Hololens and Visual Studio. Unsure what the issue is, you can see the specific error code below:
Severity Code Description Project File Line Suppression State
Error DEP0100 : Please ensure that target device has developer mode enabled. Could not obtain a developer license on 127.0.0.1 due to error 80004005. Planetarium

Answers

  • @philosoVR

    Is your dev machine also set to Developer Mode?

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • Okay, as it turns out, I have been battling with the same error for the last couple of days and boy is this frustrating.

    So here are some of the many things I have tried so far:

    • Restart VS
    • Restart Machine
    • Restart HoloLens
    • Unpair all then pair again
    • VS Repair
      (note: the repair did complain about the version of C++ redist files for 2015, so I removed them and ran Repair again)

    • Reset Credentials (via Edit on the Companion App)

    • Turn off Dev Mode on HoloLens, then turn it back on (also combined with varios restarts of HoloLens along with Unpair, then pair again)
    • Tried deploying over Wireless and tethered USB
    • Uninstalled the previous version of the app from the HoloLens from Device Portal
    • Clean Solution

    I did also receive the following message in some cases:

    Severity Code Description Project File Line Suppression State
    Error DEP6957 : Failed to connect to device '192.168.1.xx' using Universal Authentication. Please verify the correct remote authentication mode is specified in the project debug settings. 0x8007274C: The network event being waited on triggered an error.

    The device is my main device and currently has version

    • 10.0.14393.448 of Windows Holographic
    • firmware revision number 0005.05.P.1606291233R

    What is really bizarre is that I have a number of HoloLens here and I have found that two others that I have tried do not have a problem with deploying the exact same project from the exact same dev machine with all the exact same conditions in the dev environment.

    One device that works still has 14393.321 on it, so for a while I thought it might have been a problem with the OS version, but then I tried the other device that also has 14393.448 on it, and it worked fine therefore if it is related to that version of OS is appears to be intermittent.

    So it would seem that this particular problem (or at least my encounter with it) is specific to the state that a particular HoloLens can get into since my exact same dev environment will deploy to two different devices even though it will not deploy to this one. As a matter of fact even after several hours of failed attempts and experiments to deploy to that one problematic device with the error still showing in Visual Studio I was then able to simply point one of the other devices IP addresses in my remote machine target and it deployed just fine. No need to close VS, reboot or any of that kind of thing.

    Based on the message, it kind of seems like there is a bug in the Windows Holographic Dev Mode logic where even though the device is in Dev Mode with Device Portal setting turned on, it for some reason is not giving VS the love that it needs during the deploy process.

    This msdn page describes some of the Dev Mode and pairing stuff and talks about how turning on Dev mode that it enables a package of options that include some firewall and SSH stuff, perhaps since the Windows Holographic seems to have an abbreviated set of options for developers the simplified set of options are somehow not robust enough to recover from some combination of events.

    The one thing I have not tried yet is to Reset the device since I rather not have to start from scratch afterwards losing all of the apps and configuration. Hoping that @DavidKlineMS, @Patrick or one of the HoloLens team members can provide more insight as to whether there are any other ways to get the device to clean up its Dev Mode state without wiping it all, given there is no command line options. :-)

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • giova984giova984
    edited October 2017

    Hi,
    I'm experiencing the same issue and did the same tries as HoloSheep with no luck. I only have 1 HoloLens and I'd prefer not to reset it.
    My HoloLens OS version is 10.0.14393.1715 (I also tried before updating it) and windows 10.0.15063 (also tried before updating to the creators update).
    In particular I want to build and deploy the MixedRealityToolkit which requires Unity 2017 and VS 2017.
    I'm able to build the appx and install it on the HoloLens using Unity, but I lose the Debug capabilities without VS.
    I'm still able to build and deploy older apps using VS2015 (but I cannot use VS2015 to build the new MixedRealityToolkit)
    Thanks

  • I'm having the same problem as above- app builds fine. Can't deploy over Wifi or USB.

    Hololens OS is 10.0.14393.2068
    firmware 0005.05.S.1801091036R
    Development PC
    Windows 10.0.16299 Build 16299 (Windows 10 Home)
    Using VS2017 ver 15.5.7
    Unity 2017.3.1f1

    Any help would be great. Can't make any progress at this point.

  • i resetted my device just few days ago and again its showing the same error. this is very frustrating. Did you get any solution for this??

Sign In or Register to comment.