Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Unable to launch HoloLens emulator

Hello,

I have installed everything according to below link

https://developer.microsoft.com/en-us/windows/holographic/install_the_tools

But, whenever I try to start emulator's VM from Hyper-V Manager, I got below error.

'HoloLens Emulator 10.0.11082.1039.maverick' failed to start. (Virtual machine ID B01C031B-F4DF-442F-9C7D-722463B98EA9)

'HoloLens Emulator 10.0.11082.1039.maverick' Synthetic 3D Display Controller (Instance ID 113560EA-48CD-4BD1-8828-FCEC44E2B5D5): Failed to Power on with Error 'Insufficient system resources exist to complete the requested service.' (0x800705AA). (Virtual machine ID B01C031B-F4DF-442F-9C7D-722463B98EA9)

'HoloLens Emulator 10.0.11082.1039.maverick' Synthetic 3D Display Controller: Failed to Power on with Error 'The virtual machine cannot be started because the file rdvgm.exe that is required to start the RemoteFX Manager process does not exist.'. (Virtual machine ID B01C031B-F4DF-442F-9C7D-722463B98EA9)

I have two graphics adapters
1) Intel(R) HD Graphics 4600
2) NVIDIA GeForce GT-740M

I tried using both the graphics cards as "Remote FX 3D Video Adapter" in Hyper-V settings but no luck.

I will appreciate any help.

Thanks & Regards,
Owais.

Tagged:

Answers

  • OwaisOwais
    edited April 2016

    I dig into RemoteFX and reached the logs, seems like issue with RemoteFX starting, I tried Windows 10 Phone Emulator with RemoteFX support and it failed in similar fashion. So, problem is localized, I will appreciate if anyone can help on this. I am using Windows 10 x64 Education version.

    The Virtual Machine Management Service could not start the RemoteFX Manager process to enable RemoteFX for the virtual machine HoloLens Emulator 10.0.11082.1039.maverick. Affected virtual machine id is 27B92739-C75B-415B-9C63-1C824F7A9131. Try restarting the Virtual Machine Management Service. Error message: This network connection does not exist.
    Status Code: 3066107976.

  • I see a couple of threads about this issue with the phone emulator. The HoloLens emulator will have the same issues. One user references a thread on StackOverflow suggesting that disabling the secondary video card in device manager works around this. A thought is to ensure that you have the latest WDDM version of your graphics drivers.

    This thread has some things to double check in your BIOS to ensure everything required for Hyper-V is enabled.

    One user solved their problem by clean installing Windows 10. I'm not fond of this solution. I have a suggestion that is more targeted that perhaps you could try for us.
    Disable Hyper-V, reboot, then enable Hyper-V
    1. Go to Add/Remove programs (Windows+r, type 'appwiz.cpl' into the run box, press enter)
    2. Select 'Turn windows features on or off' (it's on the left hand side in tiny text)
    3. A dialog will popup, scroll down a bit and you'll see 'hyper-v'. Uncheck it.
    4. Reboot.
    5. Run steps 1-4 again, but on step three check the box rather than unchecking the box.
    6. You may also try uninstalling and reinstalling the HoloLens emulator.

    Do let us know if you find something that works. The problem is beyond us, so if we can find a way to fix this, we're helping a lot of people.

    Cheers,

    Patrick

    This post is provided with no warranty and confers no rights. Use information provided at your own risk.

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • Hello Patrick,

    Thanks for response,

    I tried all you mentioned(except re-installing Windows) and similar solutions posted on different forums by Googling the problem but none of them worked.

    Thanks & Regards,
    Owais.

  • edited June 2017

    Having the same problem here. Anyone find a fix?

    I noticed that the Hyper-V Manager setting pane for the Physical GPUs shows the GPU Details and in the Summary it says that '0 virtual machines are currently using this GPU. 0 MB out of a total 24480 MB of VRAM is currently provisioned to these virtual machines.'

    I'm assuming this says no VRAM is allocated to running VMs, not that the VM cannot allocate any memory if it were to be launched/running. I don't see anywhere to dedicate any memory to a VM. The GPU Details does show a Capabilities list that includes Dedicated Video RAM: 8119 MB and Dedicated System Memory: 0 MB...

    I've attached an screenshot of the GPU settings.

    I didn't create this VM, it was created by the HoloLens emulator setup.

    Help?

  • I am also getting this same error. Uninstalling/reinstalling Hyper-V didn't fix the result, nor did uninstalling/reinstalling Hololens emulator. I've tried this on two different systems, one with VS2017 and the other with VS2015 Update 3, but both had SDK 10.0.14393.0 installed and Unity 5.6.2.f1. Same error.

    On my systems, I only have one graphics source (Intel HD Graphics 530 on my laptop or the Intel HD Graphics 4600 on my dekstop, no other graphics card/source).

    Regards,
    Tam

  • I finally got this resolved on my end. The issue for me was that on both my laptop and my desktop setup, the GPU just wasn't powerful enough (Intel HD Graphics 4600 & 530). I moved my development to a Surface Book which has a built-in NVidia GeForce GPU, and the emulator error no longer showed up, and my Hololens app started without issues. Details of the GPU from Speccy state that the Surface Book I'm using has:

    VVX14P048M00 ([email protected])
    Intel HD Graphics 520 (Microsoft)
    1023MB NVIDIA GeForce GPU (Microsoft)
    ForceWare version: 376.67
    SLI Disabled

    Hope that helps for anyone who may be experiencing similar issues.

    Tam

Sign In or Register to comment.