Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Set Cloud Server for HoloLens Sharing Service

Hi,

I followed the tutorial of HoleLens-240 and successfully used my local computer as server for shared experience between HoloLens. Right now I established a windows server on the Google Cloud and I wish I could hold the Sharing Service on the cloud server.

Here is what I did on the windows server:
1. cloned the whole 240 course project folder to the windows server.
2. navigated to Assets/HoloToolkit-Sharing-240/Sharing
3. ran command ''./SharingService.exe -local'' using gitbash

The terminal shows up the same message as it would when I establish the SharedService.exe on my local computer. However, when I opened the app on HoloLens, it never connected to the SharingService on the cloud server.

Here is what I tried:

  1. Change server address in the unity editor to the Local IP address showed up on the terminal after launching SharingService.exe on the server.
  2. open up the port 20601. 20602 in the windows firewall setting. (and if I do netstat -n -a, I can see those two ports shows up)
  3. Set up Externel IP on the Server and use "route add -p [Externel IP] [Local IP address]" to set the local ip address as gateway, and then change server address in the unity editor to Externel IP and tried again.

But none of them worked, it looks like HoloLens never joined the Sharing Service session on the cloud server.

I am new to HoloLens and network stuff, so probably the question is stupid. But can someone give help about how to set this up, so that I can have the SharingService keep running on the server and have HoloLens connect to it?

Deeply appreciate your help!

Answers

  • mdickensmdickens
    edited June 2017

    (deleted as not relevant)

  • I cant even get this working on a local network. Tried everything. Can even see packets on the network but Hololens is stupid and silent.

  • Hi,
    I'm having trouble getting sharingservice.exe to run online, so have you solved that problem now? Could you please suggest me a solution, thank you so much

Sign In or Register to comment.