Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Acer Mixed Reality - USB3 PCI Card not working

Hi, I have the ACER Mixed Reality headset and have been unable to get it to work, the Portal shows me all green ticks for cpu, memory, usb3 and so on, but then fails to find the device.

Under Device Manager all the sensors and such show up, but the HoloLens Sensors under Mixed Reality devices shows an error:

"This device is not working properly because Windows cannot load the drivers required for this device. (Code 31) The process hosting the driver for this device has terminated."

I get the same issue if plugged into USB2 on motherboard also

Driver details show provider as Microsoft, version '10.0.16238.1000'

Under Events it lists 'Device not started WUDFRd'
"Device USB\VID_045E&PID_0659&MI_04\7&17b2c987&0&0004 had a problem starting.

Driver Name: oem3.inf
Class Guid: {D612553D-06B1-49CA-8938-E39EF80EB16F}
Service: WUDFRd
Lower Filters:
Upper Filters:
Problem: 0x1F
Problem Status: 0xC0000450"

I imagine this will be the same kind of issue people have with Kinect sensors being really fussy about USB chipsets, and if the advice is anything to go by for that I have no hope, a handful of recommended cards most of which are US only ( I am in the UK ) and then the reviewers for which are a mixed between it destroyed my computer and it destroyed the device I plugged into it.

I am using a 'Fresco Logic USB 3 PCI card' / 'Inateck 4 Ports PCI-E' 'FL1100 chipset' in a Mac Pro 2010 Tower Intel Xeon X5690 x 2, USB driver is the Microsoft 10.0.15063.296, though I tried Fresco Logic driver also which worked even less ( nothing showed up )

I have tried with all other devices unplugged also

The Oculus Rift, and HTC Vive all work just fine on my USB3


  • I have the same issue. Someone please help us.

  • @HeliosDoubleSix Thank you for the feedback. Have you upgraded to the latest Insider Preview version? Current ver is 16257.

    If so, We'd like to learn more about what's happening so we can try to help.

    1. Can you share a screenshot of the system check?
    2. Can you also share your OS Build number? (Settings > System > About > OS Build)
    3. We might need you to submit feedback to get more details, but no need to do that yet.
  • I have the same problem with a Vantec Gen II USB 3.1 PCIe card.

  • Is it possible those cards aren't able to provide enough power to the headset ? Do we need an usb 3.0 hub with external power ?

  • edited August 2017

    Any solution for that?
    I have the Acer HMD for a Month and I can't use yet for MR... Only to be cool over the table... ¬¬

  • edited August 2017

    Anybody have a solution yet?

  • I've got the exact same issue. identical error codes.

    I've tried three pci usb cards with failure:
    fresco/inateck ktu3fr-202i,
    dodocool USB 3.1 Gen II,
    Mailiya 4 port usb 3.0
    my motherboard also has integrated realtek usb 3.0.

    I've also tried using a usb Y-cable to double the amperage.
    I've also tried a fresh win 10 installation

    no luck or changes with any of these.

    I've also spent hours on customer service chat with microsoft and having them remote access my computer, no help at all. They said my issue was that i had 8gb of ram instead of the recommended 16gb, idiotic.

    I know its not the headset though, It works (not well) on both my laptops.

    I have a decent gtx 980 reference gpu.
    I believe the issues is my motherboard or cpu they are fairly old.
    So for reference, I'm using a
    AMD phenom II X6 black cpu
    Gigabyte 78lmt-usb3 6.0 motherboard.

    I'm interested in hearing what other hardware people are using?

    My solution will be to wire an $8 pci-e usb card to my netbooks m.2 network card slot, to function as the gpu. And then running the headset off my netbook.

  • NoirsoftNoirsoft
    edited September 2017

    Not sure if I should post here or a new thread. Having the exact same issue with the HP model Headset. Not on an insider preview, Windows 10.0.15063. Cannot connect with either a USB 3.0 card (same one mentioned in first post) or one of the two USB 3.0 ports on my motherboard. It connects and is recognized on my office PC and on my Surface Pro (2017) though with unusable other issues on the latter.
    (more notes: also on an older CPU/Mobo. Core i7-980 with X58 chipset)

  • I'm still having this issue ... actually, my computer was unusable with 16273 (green and blue screens at boot). I removed (physically) the card from the computer and it booted properly. I'm installing 16281 update now and as soon as it is completed, I'll reinstall my card and give it a shot. I too have a totally usless Acer headset besides my computer for more than a month now.

  • Sorry for the delayed response. The USB Add-in cards listed in this thread running the Microsoft USB XHCI driver should work with Windows Mixed Reality headsets. Please uninstall any 3rd party USB 3.0 XHCI Controller drivers.

    Windows Mixed Reality requires a CPU that supports the PoPCnt and AVX instruction set. Intel CPUs that are SandyBridge (2011) generation or later and AMD CPUs that are Bulldozer (2012) generation or later support these instructions. Please try using a PC with a more recent generation CPU.

Sign In or Register to comment.