Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Selft-built mixed reality apps in portal can run only once. After that, driver crashes

I build the app to UWP with Unity, the run it, provided I don't start it from the debugger. I can start them only once. After that, the app keeps crashing. Funny thing is that when I LEAVE the app, the 'loading' screen stays active for the app (the white screen that seems to be in the air). If I close the app, and start it again, it crashes. I need to reboot to get it to work again.

My Event log is full of this:
Faulting application name: WalkTheWorldMR.exe, version: 0.0.0.0, time stamp: 0x58dc3f10
Faulting module name: nvwgf2um.dll, version: 23.21.13.8512, time stamp: 0x597a3374
Exception code: 0xc0000005
Fault offset: 0x001705c5
Faulting process id: 0xe4c
Faulting application start time: 0x01d310f6d23fbc34
Faulting application path: C:\Projects\WalkTheWorldMR\App\WalkTheWorldMR\bin\x86\Release\AppX\WalkTheWorldMR.exe
Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\nvgbdi.inf_amd64_891b45f423af2db2\nvwgf2um.dll
Report Id: aaabee99-726c-4251-9987-959a89366976
Faulting package full name: WalkTheWorldMR_1.0.

So the driver of my GTX 1070 is going down. But only the SECOND time it is called. This happens even with a simple app that does nothing, only has the camera in it.

Tried downgrading the driver, also tried upgrading to beta. To no avail. Effectively this is blocking me porting my HoloLens apps to Windows Mixed Reality.

Answers

  • Hi, I am working for a big automotive company and we have the exact same issue here. Our HoloLens application works only once in the Mixed Reality Portal with the exact same error on the second run. We were trying the development version of the Acer headset on a 1080 GTX.

    We can add that we tried it first a month ago on 1703, it started once and worked as expected and after that we did not get it to work again. After the 1709 update it worked again for one single time and since then it keeps crashing.
    We also see the exact same behaviour in the simulator.
    Here our crash report (App name changed to AutomotiveApp):

    Faulting application name: AutomotiveApp.exe, version: 0.0.0.0, time stamp: 0x58dc3f10
    Faulting module name: nvwgf2um.dll, version: 22.21.13.8569, time stamp: 0x59bd577b
    Exception code: 0xc0000005
    Fault offset: 0x0018b5ab
    Faulting process id: 0x221c
    Faulting application start time: 0x01d348b86bdd1527
    Faulting application path: C:\Program Files\WindowsApps\AutomotiveApp_1.4.2.71_x86__8pmhy0ftatmam\AutomotiveApp.exe
    Faulting module path (App name changed to AutomotiveApp): C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_841d56cc807f1f4d\nvwgf2um.dll
    

    We also get a couple of warnings looking similar to this in the event log:

    Fault bucket , type 0
    Event Name: MoAppCrash
    Response: Not available
    Cab Id: 0
    
    Problem signature:
    P1: AutomotiveApp_1.4.2.71_x86__8pmhy0ftatmam
    P2: praid:App
    P3: 0.0.0.0
    P4: 58dc3f10
    P5: nvwgf2um.dll
    P6: 22.21.13.8569
    P7: 59bd577b
    P8: c0000005
    P9: 0018b5a8
    P10: 
    

    We can provide more detailed information to Microsoft on request. We really need a fix for this because it is blocking entire production teams to use these new headsets.

  • Hi @Maik,

    I am from the Microsoft team. It looks like this is a crash in a module owned by NVIDIA. My first instinct would be to follow up with NVIDIA on the crash. They may ask for a crash dump, which might be alongside the place where you copied the diagnostic data above (depends on your organization's diagnostic data collection policies). Using the crash dump, they might be able to root cause the problem and provide a fix or workaround.

    I don't believe there is anything that Microsoft can assist with here, because we don't have access to NVIDIA source code. However, I did some investigation work to see if anyone else around here has encountered this before. Unfortunately, I didn't find anything relevant. I'm also not finding anything related to AutomotiveApp, but maybe that's what you mean when you state "App name changed...".

  • Jimbohalo10Jimbohalo10 ✭✭✭
    edited November 2017

    Hi @maik Your NVidia driver is dated 9th September 2017. There seems discussion about problems with this driver. Therefore please update to 387.92

    There is often a requirement to have a NVidia driver far in advance of those delivered by Windows 10 Update.
    The new driver is WHQL verified anyway

    If you app fails check the code that you have DE-allocated all the resources used for the 3D graphics and any other calls. The error code is access denied, which usually means another process has this resource locked. This could be because the process run down code has a block of memory still allocated, just like in the old C++ malloc memory problem where resource were not released resulting in memory leaks.

    Remember that HoloLens was is able to allow many copies of a resource code, because it is basically mobile phone unique Windows 10 system

    Immersive headset development working in real PC development land where only one copy is allowed and over allocation is detected. This means code working on HoloLens is not subjected to strict control because much of the code is a subset of desktop Windows 10 as the HoloLens does not support. Multiplayer or multitasking

Sign In or Register to comment.