Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

“Assembly-CSharp-firstpass.dll could not be found." How to fix this compilation error?

The project— my very first—is a barebones one: “Holograms 100,” which is a Windows Dev Center tutorial. I planned to test it using Hololense Emulator (version 10.0.14393.1358).

I open MixedRealitySolution.sln in Visual Studio and attempt to compile it.

I repeatedly get message that “firstpass.dll” cannot be found; also that “Assembly-firstpass cannot be found. I did find the firstpass.dll in a folder called “Unprocessed;" it was only 4 kb.”

ERROR CS006: Metadata file 'C:\Users\Jumper\Documents\myUnity5\MixedRealityIntroduction\App\GeneratedProjects\UWP\Assembly-CSharp-firstpass\bin\x86\Release\Assembly-CSharp-firstpass.dll' could not be found

ERROR CS006: Metadata file 'C:\Users\Jumper\Documents\myUnity5\MixedRealityIntroduction\App\GeneratedProjects\UWP\Assembly-CSharp\bin\x86\Release\Assembly-CSharp.dll' could not be found

I am using Unity Beta version 2017.2.0b8 along with Visual Studio Community 2017 Version 15.3.2 (.NET Framework: 4.6.0138). My operating system is Windows 10 Professional: version 1511 (OS Build 10586.318). I had previously enabled Hyper-V in both BIOS and Windows.

In Unity, for the player properties that related to the settings for Universal Windows Platform, I did target Windows 10 SDK: for the rendering section. That is to say, I checked the Virtual Reality Supported checkbox to add a new Virtual Reality SDKs list and confirmed "Windows Mixed Reality" was listed as a supported SDK. That is to say, the Virtual Reality SDKs was set to Windows Holographic.

In Unity’s “Configuration” section:

Scripting Runtime version: Experimental (.NET 4.6 Equivalent); Visual Studio Community 2017 Version 15.3.2 uses .NET Framework: 4.6.0138. I also tried the only other choice of “Stable (.NET 3.5 Equivalent).

Scripting Backend: .NET

API Compatibility Level: .NET 4.6

In Unity’s “Build Settings:”

Platform: Universal Windows Platform

Target: Any Device

Build Type: D3D

Build and Run: Local Machine

Debugging: I checked “Unity C# Projects” only; also, I tried both “Unity C# Projects” and also “Development Build.”

SDK: Latest Installed (the only alternative was 10.0.15063.0). I did also try the alternate setting.

The relevant Visual Studio settings are as follows:

Solution configuration: Release

Solution platform: x86

Hololens Emulator 10.0.14393.1358


1, Several times, I repeated the tutorial from scratch, especially always double-checking that I made the correct property settings for the player, configuration and building.

  1. I reinstalled both Unity and Visual Studio Community.

  2. I placed solution in root folder of hard drive and opened Visual Studio; I thought perhaps problem accessing file path that was too long. There are no spaces or special characters in the original file path.

  3. In Visual Studio, I made sure, in Nuget Package Manager Settings, that in the Package Restore Section, both “Allow NuGet to download missing packages” and “Automatically check for missing packages during build" were checked. In another attempt at solving problem, I unchecked both of them, closed Visual Studio, then I relaunched program, re-checked the two items and attempted to compile.

  4. I have spent countless hours searching and trying likely solutions Unity and Microsoft sites, as well as various forums.

Please advise; I would be most appreciative.


Sign In or Register to comment.