Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Weird behavior when moving an Object with HandDraggable and WorldAnchor Manager methods

Okay so I have an object I want to move with HandDraggable.cs but, I also want to be able to use world anchors on it. However, I do not want to use TapToPlace, but in essence I am doing the same thing that TapToPlace does.

Basically I have a button on my object that when I press it I remove the anchor that is on it through the WorldAnchorManager and enable HandDraggable on it. When I press the button again it does the opposite, disables HandDraggable and attaches a world anchor to the object.

The weird behavior happens sometimes but, not all of the time. Basically what happens is that whenever I go to remove the Anchor sometimes the object moves across the room and becomes attached to the camera sort of like the TapToPlace script does but with opposite movements. If I move toward it, then the object moves toward me, etc. HandDraggable also doesn't work either. When I click the button again, the object gets an anchor correctly and it doesn't move anymore. Once this behavior occurs it repeats itself until I restart the app.

Does anyone have any insight on what might be happening? I don't get any errors or warnings in the debug.

AR Developer

Tagged:

Answers

  • Update: so I found that it is the HandDraggable is the problem. When I enabled and disabled the script it sometimes started manipulating another object.

    AR Developer

Sign In or Register to comment.