Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

'Focus' and 'HUX' doesnt exist

AdeelAdeel
edited December 2017 in Q&A and Discussions

I started a project from MR Design Lab which is interacting objects. but there are certain errors which are i am facing.
**The type or namespace name Focus' does not exist in the namespaceHUX'. Are you missing an assembly reference?
**
**The type or namespace name InteractionSourcePressType' could not be found. Are you missing an assembly reference?** **The type or namespace nameInteractionSourceUpdatedEventArgs' could not be found. Are you missing an assembly reference?
**

Previously on the same settings i worked on different applications and it worked perfectly i dont know whats the problem

Script association is also getting lost again n again. Is that a bug in Unity ?
any ideas ?

@neerajwadhwa

Thanks in Advance

Tagged:

Answers

  • @Adeel,

    Here's a quick suggestion. Look to see if your app is throwing any compile errors. This could prevent the various components from compiling and give you mysterious and misdirecting exceptions like this.

    James

    James Ashley
    VS 2017 v5.3.3, Unity 2017.3.0f3, MRTK 2017.1.2, W10 17063
    Microsoft MVP, Freelance HoloLens/MR Developer
    www.imaginativeuniversal.com

  • Unity is Unable to create the whole project for VS2017 i dont know maybe its some kind of a bug or a real errors its shitty cuz of Unity is updating itself but the tutorials and help on Microsoft Hololens page is still on the support the previous versions. No information regarding the new unity updates.

  • Hi You need to be using (Updated MRTK Unity Editor to 2017.2.0p2 MRTP 5 updates)[https://github.com/Microsoft/MixedRealityToolkit-Unity/pull/1433]

    The update now only support this version and hence crashes occur

Sign In or Register to comment.