Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

USB Power surge with HP Mixed Reality Headset

bingbongbingbong
edited July 2018 in Troubleshooting

I have received my headset today and was so excited to use it, I used my Alienware 15 r2 laptop to connect the headset to, However every time I plug it in I get this message: "Power surge on the usb port Unknown USB Device needs more power than the port can supply"
Is the headset defective? is it because im using a laptop that the power from a single usb port is not enough? Can a perephial like this make my headset work?

Or am I better off going with a usb hub with external power adapter? A solution is greatly appreciated, thanks.

P.S: The headset only worked once, so I think its a power delivery issue?

Answers

  • It should relate to your PC setting.
    you could try:
    uninstall and re-install the USB drivers (automatic) // via device manager

    if you are using one already, remove a USB hub and try connecting directly to the Laptop

    under "Device Manager", right click on all "Generic USB ports" and "USB Root Hub controllers" then click on properties, then cick on the Power Management tab, and uncheck the box that says "allow this computer to turn off the device to save power".

Sign In or Register to comment.