Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Controllers jitter and fly off into the distance

Hi!

I recently picked up a Windows Mixed Reality HMD with two controllers. Everything works fine but I'm experiencing some difficulty with frequent 'tracking' issues.

This is what happens:

In any game (WMR House, Steam VR House, Steam VR games; tried Longbow, Google Earth) the setup works without issues the first few minutes. Controllers are tracking perfectly in relation to the HMD and each other, no jitter, smooth.
But after 10 minutes or so, the controllers start behaving erratically; jittering, disappearing. And often times both controllers 'fly off into the distance', I think about 20 meters away in front of me. It appears to me as if the game thinks that I'm standing in a different spot at that moment. With 'fly off' I mean that the controllers suddenly disappear in front of me and appear in the distance. This all happens instantaneously without any transition, just to be clear. After some time (30 secs or so, varies) the controllers reappear in front of me. This cycle continues.

At first I thought that Steam VR might be the culprit, but running the WMR House without Steam and Steam VR running at all, this behavior still occurs.

I tried swapping the controller batteries for fresh ones; no effect.

I tried different lighting conditions; no effect.

At this moment I'm at a loss how to fix this. I can't pinpoint the issue. Do any of you know what the problem might be? Have any of you experienced this kind of behavior? Any help or insight is greatly appreciated! Thanx guys!

Greetings,
Bastiaan

Sign In or Register to comment.