Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

IOException: Sharing violation on path - No script - Following Holograms 100 tutorial

Hello, I am new to this, just installed everything according to MS website, including Unity 5.5.0f3 Personal. I searched and read similar error message postings, but did not find a solution.

Following the Holograms 100 tutorial, created a very simple 3D cube. No scripts, nothing fancy, everything according to the tutorial. Here are the Build Settings:

Platform: Windows Store SDK: Universal 10 Target Device: Any device UWP Build Type: D3D Unity C# Projects: Checkbox is checked

Followed tutorial for settings, and the Project Settings-Quality settings.

When clicking Build button, and selecting folder, the only file built is an empty 1KB Visual Studio solution file (.sln), and get the following error in the Unity Console:

IOException: Sharing violation on path Temp\StagingArea\TempSerializationWeaver\UnityEngine.UI.dll System.IO.File.Move (System.String sourceFileName, System.String destFileName) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.IO/File.cs:339) PostProcessWinRT.RunSerializationWeaver () (at C:/buildslave/unity/build/PlatformDependent/WinRT/SharedSources/CSharp/PostProcessWinRT.cs:433) PostProcessWinRT.Process () (at C:/buildslave/unity/build/PlatformDependent/WinRT/SharedSources/CSharp/PostProcessWinRT.cs:124) UnityEditor.WSA.BuildPostprocessor.PostProcess (BuildPostProcessArgs args) (at C:/buildslave/unity/build/PlatformDependent/MetroPlayer/Extensions/Managed/ExtensionModule.cs:155) UnityEditor.PostprocessBuildPlayer.Postprocess (BuildTarget target, System.String installPath, System.String companyName, System.String productName, Int32 width, Int32 height, System.String downloadWebplayerUrl, System.String manualDownloadWebplayerUrl, BuildOptions options, UnityEditor.RuntimeClassRegistry usedClassRegistry, UnityEditor.BuildReporting.BuildReport report) (at C:/buildslave/unity/build/Editor/Mono/BuildPipeline/PostprocessBuildPlayer.cs:186) UnityEditor.HostView:OnGUI()

I tried Unity version 5.4.0f3 to rule out the Unity version (being the latest), with the same error and results. I also verified I have Tools (1.4.1) and Windows 10 SDK (10.0.14393) installed in Visual Studio.

Is there something not covered in the tutorial? Is anyone else getting this error? I don't know what else to look for. Any help would be greatly appreciated.

Tagged:

Best Answer

Answers

  • @JinSea,

    Just checking but are you creating a new, clean folder when you do your export from Unity?

    James Ashley
    VS 2017 v5.3.3, Unity 2017.3.0f3, MRTK 2017.1.2, W10 17063
    Microsoft MVP, Freelance HoloLens/MR Developer
    www.imaginativeuniversal.com

  • @JinSEA,

    Cool. Glad you got it figured out.

    James Ashley
    VS 2017 v5.3.3, Unity 2017.3.0f3, MRTK 2017.1.2, W10 17063
    Microsoft MVP, Freelance HoloLens/MR Developer
    www.imaginativeuniversal.com

Sign In or Register to comment.