Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Connecting to webservice

Hi
I have to connect with webservice to get some values online.
I use this code :

IEnumerator Download()
{
// Pull down the JSON from our web-service

WWW w = new WWW(
  "url"
);
yield return w;

}

it works in unity but when I run the app in hololens emulator the result always returns empty "".

Any help?

Thanks

Best Answer

Answers

  • look for w.text
    Also check if you are receiving a 404 or if you have cross domain issue.

    If its a rest service you might want to look at WWWForm and post the data WWW(url,data,headers)

    markval.com - All around Digital

  • No
    always w.text=""
    but when I run the app in unity, it works perfectly

  • Are you using localhost?

    Look for w.error then. If you are receiving some data you might want to check to progress and bytesDownloaded.
    https://docs.unity3d.com/ScriptReference/WWW.html

    What's your server? Are you using Post or Get? Is it a socket?

    markval.com - All around Digital

  • It is an online webservice. it just returns simple json string (just for testing).
    It is GET.
    It works in Unity :) . just string

  • SoubhiSoubhi
    Accepted Answer

    I have to add Capability (Internet)

  • @Soubhi said:
    I have to add Capability (Internet)

    This is in the Package.appxmanifest file --> Capabilities Tab. ;)

Sign In or Register to comment.