Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Unable to Install Hololens Emulator. Error: Please install Visual Studio 2015 with Update 1 and UWP1

I am struggling to setup Hololens Emulator in my PC.

System Specs:

**> Windows10 Pro

8 GB Primary Memory
Intel i7 Processor
Hyper-V is enabled
Virtualization is Enabled in the BIOS
I have disabled the firewall and windows defender**

I am referring this link to setup the development for hololens development.
https://developer.microsoft.com/en-us/windows/mixed-reality/install_the_tools

I have successfully installed Visual Studio 2017 , the problem arises when I try to install the hololens emulator (build 10.0.14393.0) and it will fail, because the setup expects Visual Studio 2015 Update 1.

This is the short text:

Please install Visual Studio 2015 with Update 1 and UWP tools version 1.2, then run setup again.

Note: I unsuccessfully tried to setup every update of Visual Studio 2015 (1/2/3) all the community editions but they all gave me a "Stopped Working error". I even tried with ISO versions and the result is equivalent.

Here is a snapshot of the system log:

MSI (s) (10:E8) [10:15:31:257]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE32\SOFTWARE\Microsoft\DevDiv\Servicing\14.0\core 3: 2
MSI (s) (10:E8) [10:15:31:257]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (s) (10:E8) [10:15:31:257]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE32\SOFTWARE\Wow6432Node\Microsoft\DevDiv\Servicing\14.0\core 3: 2
MSI (s) (10:E8) [10:15:31:258]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (s) (10:E8) [10:15:31:258]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE32\SOFTWARE\Microsoft\DevDiv\Windows\Servicing\14.0\toolscore 3: 2
MSI (s) (10:E8) [10:15:31:258]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (s) (10:E8) [10:15:31:258]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE32\SOFTWARE\WOW6432Node\Microsoft\DevDiv\Windows\Servicing\14.0\toolscore 3: 2
MSI (s) (10:E8) [10:15:31:259]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (s) (10:E8) [10:15:31:259]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE32\SOFTWARE\Microsoft\DevDiv\vs\Servicing\15.0\devenv 3: 2
MSI (s) (10:E8) [10:15:31:259]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (s) (10:E8) [10:15:31:259]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE32\SOFTWARE\Wow6432Node\Microsoft\DevDiv\vs\Servicing\15.0\devenv 3: 2
MSI (s) (10:E8) [10:15:31:260]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (s) (10:E8) [10:15:31:260]: PROPERTY CHANGE: Adding WIN10TLS_PREVIEW property. Its value is '15.0.26208'.
MSI (s) (10:E8) [10:15:31:261]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (s) (10:E8) [10:15:31:261]: PROPERTY CHANGE: Adding WIN10TLS_PREVIEW_WOW property. Its value is '15.0.26208'.
MSI (s) (10:E8) [10:15:31:261]: Doing action: LaunchConditions
Action ended 10:15:31: AppSearch. Return value 1.
Action start 10:15:31: LaunchConditions.
MSI (s) (10:E8) [10:15:31:262]: Doing action: ValidateVisualStudioVersionCustomAction
Action ended 10:15:31: LaunchConditions. Return value 1.
MSI (s) (10:88) [10:15:31:264]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI6A70.tmp, Entrypoint: ValidateVisualStudioVersion
MSI (s) (10:80) [10:15:31:264]: Generating random cookie.
MSI (s) (10:80) [10:15:31:265]: Created Custom Action Server with PID 2200 (0x898).
MSI (s) (10:90) [10:15:31:287]: Running as a service.
MSI (s) (10:90) [10:15:31:288]: Hello, I'm your 32bit Impersonated custom action server.
Action start 10:15:31: ValidateVisualStudioVersionCustomAction.
ValidateVisualStudioVersion: Initialized.
ValidateVisualStudioVersion: Loaded a property value. Name: TARGETVISUALSTUDIOVERSION, value: 14.0.24720.
ValidateVisualStudioVersion: Acquired target VS version string: 14.0.24720.
ValidateVisualStudioVersion: Loaded a property value. Name: TARGETWINDOWSSDKVERSION, value: 14.0.24720.
ValidateVisualStudioVersion: Acquired target Windows SDK version string: 14.0.24720.
ValidateVisualStudioVersion: Could not loaded a property value. Name: VS14UPD1
ValidateVisualStudioVersion: Could not loaded a property value. Name: WIN10TLS1_2
ValidateVisualStudioVersion: Could not loaded a property value. Name: VS15
ValidateVisualStudioVersion: Loaded a property value. Name: WIN10TLS_PREVIEW, value: 15.0.26208.
ValidateVisualStudioVersion: Acquired installed Windows SDK preview version string: 15.0.26208.
ValidateVisualStudioVersion: Could not loaded a property value. Name: VS14UPD1_WOW
ValidateVisualStudioVersion: Could not loaded a property value. Name: WIN10TLS1_2_WOW
ValidateVisualStudioVersion: Could not loaded a property value. Name: VS15_WOW
ValidateVisualStudioVersion: Loaded a property value. Name: WIN10TLS_PREVIEW_WOW, value: 15.0.26208.
ValidateVisualStudioVersion: Acquired installed Windows SDK preview version string from Wow6432Node: 15.0.26208.
ValidateVisualStudioVersion: Error 0x80070057: Failed to acquire a detected Visual Studio version property string in custom action.
MSI (s) (10!24) [10:15:31:311]: Product: HDE 10.0.14393.0 -- Error 1608. This product requires Microsoft Visual Studio 2015 with Update 1 and UWP tools version 1.2.

Please install Visual Studio 2015 with Update 1 and UWP tools version 1.2, then run setup again.

Error 1608. This product requires Microsoft Visual Studio 2015 with Update 1 and UWP tools version 1.2.

Please install Visual Studio 2015 with Update 1 and UWP tools version 1.2, then run setup again.

Comments

Sign In or Register to comment.