Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Opening scripts in the right visual studio solution

So, on this page (Best practices for working with Unity and Visual Studio) they suggest using Unity C# projects to have one instance of Visual Studio to both modify scripts and build.

However, when I open the scripts from the unity editor, it opens the wrong visual studio solution (the one in the root of the Unity project folder, rather than the one in the build folder). Is there a way I can change which solution file opening a script from the editor opens?

Hope that's clear enough,

Thanks in advance,

Answers

  • @mHarris
    In the Unity Editor, Edit>Preferences>External Tools>External Script Editor, select the correct VS version. That will launch the correct VS from the Unity editor.

  • @Karthik said:
    @mHarris
    In the Unity Editor, Edit>Preferences>External Tools>External Script Editor, select the correct VS version. That will launch the correct VS from the Unity editor.

    It's not the version of visual studio I'm having trouble with, it's the visual studio solution file that is opened when I open a script from Unity.

    Looks like Unity doesn't support passing in argument variables to Visual Studio 2017

Sign In or Register to comment.