Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

C++/CX, how to safely use new APIs but also run on older windows 10

I need my app to still run on the HoloLens. How do I do this

Code

      if(mStageReferenceFrame)
        mRenderer.reset(new Renderer(!HolographicDisplay::GetDefault()->IsOpaque, mStageReferenceFrame));
      else
        mRenderer.reset(new Renderer(!HolographicDisplay::GetDefault()->IsOpaque, mStationaryReferenceFrame));

Api HolographicDisplay::GetDefault()->IsOpaque only available on fall creators. How do I check that is is available before calling on my old HoloLens which crashes with Platform::ClassNotRegisteredException

I need to solve this problem before next weekend.

Answers

Sign In or Register to comment.