Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

MR controllers no longer able to connect

Hello all, and thanks in advance for any help/direction on my issue.

I was in the MS cliff house earlier today, and I got a notification of a controller firmware update. Since that time, my controllers are no longer able to connect. When I go to my Bluetooth center, I can get the device to show up for a short time, but only as an input, and not labeled as left or right controller. When I connect to it, it does not really do anything, and the controller leaves paring mode before i get any subsequent message.

So far I have done the following to no avail:

Restarted everything, from PC to controler
Factory reset controler
Reinstalled Mixed Reality
Uninstalled and reinstalled the Bluetooth and MR drivers.

I am using the Samsung HMD Odyssey.

I was able to get both controllers to show up on a laptop Bluetooth and connect as the appropriate item.
Any direction would be much appreciated, as Samsung support does not even know they are selling these apparently.

(ie> left and right controller)

Answers

  • Hey Justin734, did you ever figure out a solution? I have a similar problem where EVERYTHING was working properly until today I turned on my laptop (XPS 9560 w/ GTX 1050) and the controllers didn't show up in the portal. I than removed ALL Bluetooth controllers from Windows BT settings and when I went to re-pair them they are showing up as "INPUT". I see both controllers but cannot pair no matter what I do! I installed newest BT drivers, rebooted 1000 times, reset the controllers, turned off WIFI (interference), only tried to pair 1 controller at a time.... I have tried almost everything and still they show up as INPUT which is incorrect. My phone sees the controllers as the correct names Controller Left and Right etc. When the controllers WORKED they shows up as the same .. Left and Right etc. This is driving me NUTS and nothing I do seems to make a difference. When I try to pair the controllers they show "Connecting" but than eventually fail. The controller actually disabled pairing mode before that even happens because it isn't detecting the pair attempt (or so it seems). The WIKI you linked to doesn't help one but and I tried everything I can find on the internet.
    HELP PLEASE!
    NOTE: I have used both DELL WMR and Samsung Odyssey on this laptop with no problems. Its only the Samsung motion controllers that seem to be the issue since the headset work perfectly fine.

  • edited February 2018

    I am also having this exact problem but with the dell motion controllers. can some one please shed some light on this issue!

    The forum linked by the ever so not helpfull "Akira_Chen" was not helpful in any way. please actually try to help and not just throw unhelpful links at us.

  • As a fyi, I got an update on my machine yesterday and the same thing happened. Both controllers disappeared but still showed in Bluetooth settings. One of them popped back in after turning on and off a few times, the right one wouldn't come back at all. The instructions said to remove both, so I did, then did one at a time. As it happens, I still had the mixed reality portal open In preview mode while doing this and as I started working on the right hand controller, I noticed the floating notification about updating the controllers firmware and to not turn it off. So I sat and waited until the message went away before continuing to pair the other controller. After pairing, it didn't show up in the mixed reality portal so I just let it sit there, a minute or two in, that same updating controller firmware message popped up and three or four minutes later, the controller popped into the portal. Whatever the update is, it's poorly implemented. It should immediately pop up a "we have new firmware available for controller-left, do you wish to update it now?"(with at least a spinner letting you know it's working if not a proper progress bar, oh, and a notification it's complete). I was about to flip out yesterday.

  • I am also having this exact problem but with the Asus motion controllers. can some one please shed some light on this issue!

  • I'm having the issue as of today where my Dell controllers no longer work. I removed both and I was able to add the left controller again but it still isn't responding in MR. (It does show as connected and not paired.) I wonder if an update was pushed out over the last week?

  • justaj, my machine got one, I watched it come down in Windows Update. I then had the long process of the firmware getting updated on the controllers(with only one semi-noticeable notification) and they eventually worked correctly. See my post from the 16th.

  • @mufox77 said:
    Hey Justin734, did you ever figure out a solution? I have a similar problem where EVERYTHING was working properly until today I turned on my laptop (XPS 9560 w/ GTX 1050) and the controllers didn't show up in the portal. I than removed ALL Bluetooth controllers from Windows BT settings and when I went to re-pair them they are showing up as "INPUT". I see both controllers but cannot pair no matter what I do! I installed newest BT drivers, rebooted 1000 times, reset the controllers, turned off WIFI (interference), only tried to pair 1 controller at a time.... I have tried almost everything and still they show up as INPUT which is incorrect. My phone sees the controllers as the correct names Controller Left and Right etc. When the controllers WORKED they shows up as the same .. Left and Right etc. This is driving me NUTS and nothing I do seems to make a difference. When I try to pair the controllers they show "Connecting" but than eventually fail. The controller actually disabled pairing mode before that even happens because it isn't detecting the pair attempt (or so it seems). The WIKI you linked to doesn't help one but and I tried everything I can find on the internet.
    HELP PLEASE!
    NOTE: I have used both DELL WMR and Samsung Odyssey on this laptop with no problems. Its only the Samsung motion controllers that seem to be the issue since the headset work perfectly fine.

    It's EXACTLY the same problem and the same "solutions" that I used to try to fix the problem.

  • I had the exact same problem. Here is how I fixed it. I hope this solution is an actual fix for everyone and not just me getting lucky. :smile:

    I fixed my problem. I ended up re-installing the latest Bluetooth drivers and I powered down the PC and unplugged it for 30 seconds. Afterwards plugged the PC to power and I booted the UP back up. When the PC came back up I was able to see both controllers correctly when I attempted to re-pair the controllers within the windows Bluetooth setup window. From that point I was able to see my controller in within WMR and StreamVR again.

    Previously I reset the controllers to factory default multiple time, I re-installed the Bluetooth drivers multiple time and I rebooted the PC multiple times with no luck.

    I hope this helps someone.

  • I have the same issue with the dell controllers but I can't fix it. Bevor Windows 10 1803 every time I reboot/restart the computer I have to delete an re-pair the controllers. Now with 1803 I can only pair one controller. If I pair the first controller, I can choose between left or right controller under bluetooth devices. After I pair the first controller the other one disapear under bluetooth devices. But I have also to re-pair the controller after restarting the computer. My bluetooth adapter is a Hama Bluetooth-USB-Adapter, Version 4.0 C2 + EDR. It use the actual windows 10 built in drivers. I tried controller reset, controller firmware update etc....

  • I have switched the usb bluetooth adapter from a usb 3.0 to a usb 2.0 port an put a usb extension cable between port and adapter. Now I can pair both controllers. But after powercycle the pc or the controllers I still can't reconnect the controllers. I have to delete and re-pairing. Furthermore sometimes the controllers get lost during use. Batteries are full and they are in the field of view of the tracking cameras.

  • Im literally having the exact same problem but my controllers arent even showing on my Bluetooth connect devices, they were paired but not working, so i unpaired them they showed up as "input device" just like you are having, then i clicked stop searching (Cause they couldnt connect and POOF vanish)

  • Hey, i was wondering if anyone has yet to find a fix, thanks in advance

  • VNGVNG
    edited December 2018

    Have the same issue after unpairing controllers.
    Some time it can find controllers but when I try to connect I got "check the PIN and try connecting again". Of Course I don't have any PIN and didn't type it first time..
    Kit: samsung odyssey
    OS: Win10, 64
    OS Version: 1803
    OS Build: 17134.472

    Update: After using bluetooth troubleshooter I even can't find the controllers..

  • I am on the same WinVer as VNG. Had no issues until I updated, now it is unusable.
    ver: 1803

Sign In or Register to comment.