Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Mixed Reality Setup Error

Heyhey Guys

I just got my Samsung Odyssey from the US. Was not easy to get it here in Europe, but that's what you do if you want the best resolution :smile:

First of all, I was very impressed that the tracking worked well, I expected something else. Well done! I set up the whole thing and tried the "Windows VR House", steamVR apps and Unity. Everything worked fine.

Today, I did some stuff in Unity and tried out the Mixed Reality Simulator, so that I don't have to use the HMD for every test.

In the end I wanted to test everything with the Odyssey. The System was telling me that I should redo the "Room Setup" because of the boundaries. I guess this is normal after using the Simulator, and so did I. Unfortunately I'm stuck in the Setup, I always see this screen:

Whatever I do, the "Center" button stays grey. The Odyssey is plugged in and the device manager shows no problems. I tried:

  • restarting, reinstalling the Mixed Reality App, reinstalling the HMD drivers.

I tried everything on 3 PC's in 2 different rooms. I've got good environmental lighting in both.

Any ideas?

Cheers,
Fs

Answers

  • Not sure if this will help you, but if it is anything like my Lenovo Explorer, there is a light sensor of some sort on the center of the device. And, originally, I was trying to start the trace, with the device on the floor, or up against the wall, or with my hand over the front center of the device, all of which would prevent the start trace button from being clickable. If you are constantly not getting the trace button to be active, two minor suggestions of either 1) attempt starting a trance with the WMR device looking at a light source instead of your computer and/or 2) Have both joysticks on and active, and in front of the WMR device before starting a trace. I seem to get traces to run and consistently better when the joysticks are on in advance and are in visual range when doing the trace. Not sure if that is because they're sending light around the room or not but that could be helping.

  • Did you ever get this resolved?
    I am having the same problem and nothing seems to work.

  • I ran into a problem with the same symptom recently, and the answer was this:

    See if you have the following registry key. If so, delete it:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Media Foundation\Platform:EnableFrameServerMode

    Basically, a 3rd party SDK (for the ZED Mini) I'd recently installed added that key, and with it in place, Windows Mixed Reality tracking was completely broken. Couldn't get past that screen in setup, and if I used an already configured system, it couldn't do any positional tracking for the headset, and no tracking at all for the controllers.

    Quite a nightmare to track down, as uninstalling the SDK didn't remove the registry key. I ended up reinstalling Windows along the way (and still don't have everything else reinstalled yet).

  • Thanks @Jerrith for the info

    We also reinstalled Windows a few months later and then it started working again^^ Frankly I'm not sure what it was :neutral:

Sign In or Register to comment.