Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

CS0012 error when trying to deploy Origami (Hololens 101 tutorial) to Hololens


This is my first time using Hololens so I did everything from begining. I followed the online Holograms 101 tutorial.

Since I have a physical hololens, so I only followed the section "Installation checklist for HoloLens". I first installed a Unity 2017.4.2f2, then I installed a Visual Studio 2017 (15.6.7, community) with "UWP development" and "game development with Unity" selected.

Then I just followed the instructions in Chapter 1. Everything went well. In "Building Settings", I selected "Universal Windows Platform", "target device" is hololens, "Build type" is D3D, "SDK" is Latest installed since there is no option "Universal 10", "visual studio version" is Latest installed, "Build and Run on" is local machine, and I checked "Unity C# projects".

After opening the sln in visual studio, I set "release" "x86" "device"(my hololens is connected via usb) and then "start without debugging", and then I got the following 2 errors:

I have tried searching online for solution and I did see some people with the similar issue, but most of them are using an emulator instead of a real hololens. I have tried some solutions independent of emulator/hololens, but they didn't solve my problems.

Now I really don't know how to deal with it. I think the problem is from my visual studio because I also tried with my Unity 5.6 and it gave me the same errors. Another thing when installing the tools is that I just downloaded those listed under "Mixed Reality Toolkit", should I also build those solutions?

FYI, here are the settings of my visual studio:

And here is the player setting of my unity 2017.4.2:

Does anyone know how to solve the problem? I really need to make it work by next week and now I'm very upset :(

Thank you very much in advance for any help!!!

Have a nice weekend,




  • My guess is you didn't "switch platform" when you did your "build settings".

    You created something "other" than a UWP app; that's why the missing reference.

  • @GerryS said:
    My guess is you didn't "switch platform" when you did your "build settings".

    You created something "other" than a UWP app; that's why the missing reference.

    Hey Gerry, thanks for your answer. Unfortuantely, this is not my case...

  • Okay guys, let me answer my own question. I have figured it out.

    If you also use win10, VS2017, and unity 2017 (I switched to 2017.2, but I guess this should also work for 2017.3/4), then in the case of these two annoying "assembly that is not referenced" problem, check whether you have a reference called "windows" under Origami assembly->References. If it is not there, then right click References, on the left side you will see a "Browse", under the Browse, browse to add the reference which is supposed to be at:

    C:\Program Files (x86)\Windows Kits\10\UnionMetadata\10.0.17134.0\Facade\windows.winmd

    I hope this helps you guys. Good luck!

Sign In or Register to comment.