Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Hololens 2 - Factory Reset, now Windows Store is Missing

Hi,

We factory reset our Hololens device, and now it doesn't have the Windows Store application on it, which means we can't install the remote, etc.

The only thing that I can think of is that I'm using a personal Microsoft account (although getting a Work email registered is a bit of an opaque process).

I tried signing up for Windows Insider and updating -- no luck on "Fast". On "Preview" I get a warning that the content is out of date (not specific whether it's my current installation or the latest Insider build).

Anyone have a solution to either A. install the Windows Store directly onto the Hololens or B. configure the Hololens to have the store?

Thanks

Best Answers

  • SHawSHaw
    Accepted Answer

    @Evan_M said:
    I would suggest that you go to your Settings, enable Diagnostics to Full and after open Feedback Hub and report a problem about how after you factory reset the device it was missing the store. That way hopefully this gets fixed in the future.

    You might be able to turn on Settings > update > developer > turn on Dev mode and Device Portal and then after connecting to your PC see if on the Apps tab if you can see the store and then Launch it via Device Portal. It's might possible that the app exists and isn't visible? But if it's not there.

    Just asking which way did you Factory Reset? Settings > Update > Reset, or try with Advanced Recovery Companion?

    Meanwhile, are you talking about getting your device with a work account as soon as you recover it and are setting it up? Or adding a work account after you have set it as "I own this device?" and have been using it?

    Hi Evan, taking something from what you said, I tried using the Advanced Recovery Companion to restore the device, and that did the trick! The Store came back.

Answers

  • Hi Evan, thanks for your response,

    Dev mode is enabled. The store does not appear in device portal.

    I factory reset from the device itself.

    The device is on loan through Microsoft from a certified partner we're working with for a project we're porting from another device.

    I've worked with Azure a lot, and a lot of times things will not work and throw unknown, undocumented errors related to permissions or configuration elsewhere. My sense is that something about the device doesn't like my personal Microsoft account not associated with a company or Azure AAD and the manifest is installing the apps it thinks I should have.

    Also -- I have one of the earlier devices (Rev D? With the color issue).

    To be honest, we just need to get the Holographic Remoting Player onto the device, that's the only reason we even need the store. A solution to that would be equally helpful!

  • SHawSHaw
    Accepted Answer

    @Evan_M said:
    I would suggest that you go to your Settings, enable Diagnostics to Full and after open Feedback Hub and report a problem about how after you factory reset the device it was missing the store. That way hopefully this gets fixed in the future.

    You might be able to turn on Settings > update > developer > turn on Dev mode and Device Portal and then after connecting to your PC see if on the Apps tab if you can see the store and then Launch it via Device Portal. It's might possible that the app exists and isn't visible? But if it's not there.

    Just asking which way did you Factory Reset? Settings > Update > Reset, or try with Advanced Recovery Companion?

    Meanwhile, are you talking about getting your device with a work account as soon as you recover it and are setting it up? Or adding a work account after you have set it as "I own this device?" and have been using it?

    Hi Evan, taking something from what you said, I tried using the Advanced Recovery Companion to restore the device, and that did the trick! The Store came back.

Sign In or Register to comment.